Skip to main content

Original post by: Steve Godun ,


(G75VW) Hard drive weirdness. SATA controller? Or something Asus did?


Have an Asus G75VW that presented itself with a non-bootable system. Booted from a Win10 USB and chkdsk found a crapload of issues on the drive, but the drive was still not bootable. I couldn’t risk wiping the drive due to the owner’s data still being on it so I put in a 1TB hybrid drive that I had available. Rebooted from Win10 USB; BIOS saw the drive and Win10 installer saw the drive, but the Win10 installer could not partition or use it, nor could I partition it via the command line. (The “clean” command worked, but I could not create a new partition.)

Thinking perhaps the hybrid drive was bad I pulled it and plugged it into a USB enclosure, and that into another PC. That other PC was able to access the drive without issues, including creating a partition/formatting. Even after creating a new partition and transplanting it back into the Asus, the Asus still behaved poorly with it.

Then I thought perhaps the Asus didn’t like hybrid drives so I put a new 1TB hard drive in there. This one behaved even worse; BIOS didn’t see the drive at all, Windows installer took FOREVER to boot and get to the install pages, and once it got to the “where to install Windows” screen it showed the drive as having zero space. Again, putting this drive into a USB enclosure works perfectly.

Now I’m thinking it may be a SATA controller issue. I pulled an older 500GB drive off the shelf, plugged it into the Asus, and…it works perfectly. No issue whatsoever.

What’s up with this computer that it doesn’t like 1TB drives?


Asus Laptop