Skip to main content
Help

Original post by: Steve Godun ,

Title:

(P55W-B5224) "Where's the short?" Turns off when pressed.

Text:

Laptop came to me with the issue of “randomly turning off”. After some experimentation I was able to confirm this. It turns off immediately, as if there were a thermal problem. When it shuts off it will not turn on again until/unless you first press and hold the pinhole reset button on the side of the laptop for several seconds. Once you do that the battery/power LED will come back on, and pressing the power button will (sometimes) turn the computer back on. There is clearly some kind of electrical short happening, but I have no idea where it might be.

* After pressing the pinhole reset button and then pressing the power button, SOMETIMES the charging and wireless LED (on the leading edge, under the right palm rest) will briefly flash and the computer will not start. You then have to repeat the process starting with the pinhole reset button and try again.
* Once the laptop is turned on, if you just leave it alone it will run forever.
* If you apply pressure to the top of the case (e.g., when typing, or resting your palms on the palm rest) the computer will sometimes shut off. Further experimentation revealed this to be a “centralized” phenomenon; if your wrists were on the outer edges of the palm rest, or if you only touched the outermost keys on the keyboard (those closest to the outer edges), the computer was significantly less likely to shut off. But if you pressed keys in the middle of the keyboard (TYUI/GHJK/VBNM) the computer would instantly shut off 100% of the time.
* If I remove the bottom case, the problem completely disappears.
* For awhile I thought I’d isolated the problem to a single screw in the bottom center of the laptop. With this screw installed I was able to repeat the shut-down issue almost at will, and with the screw removed the computer never shut down improperly. Thinking perhaps the screw was contacting something on the underside of the keyboard I replaced it with a shorter screw but that didn’t solve the problem. What’s more, after I did NOTHING but remove the shorter screw, the problem remained. Eventually I removed the bottom of the case and the problem went away. (Putting the screw back in while the bottom of the case was off did NOT bring the problem back, so it’s apparently not related to the screw.
* For awhile I thought I had it figured out; I had taped down the ribbon cable for the power/volume buttons and after I put the laptop back together it didn’t shut down for nearly two days, then it happened again.

The inside of the bottom of the case has a metallic-looking foil covering its entirety which is conductive (used for RF shielding, I suppose). My only remaining guess is that SOME part of the motherboard is touching this shielding and causing the problem. Thing is, I have NO idea how to figure out where that’s happening.

Any ideas where I might look for this?

Device:

Toshiba Satellite P55W

Status:

open