Skip to main content
Help

Original post by: Honam1021 ,

Text:

No.Can't run Mac OS X 10.6.Because of the two reasons.

1. 10.6 support Intel CPU only

2. There isn't enough ram

Status:

open