Skip to main content

Fix Your Stuff

Right to Repair

Store

Help

Current version by: hidalgoerick ,

Text:

Hello.
 
I have an Intruder 1400, year 2003 , and i am having problems with the clutch, it works pretty well for a while after the bike is warm enough afterwhile riding it for some time for some reason the clutch stopstops working properly, i have to stop and let it cool down otherwise i wont be able to ride.
I have an Intruder 1400, year 2003 , and i am having problems with the clutch, it works pretty well for a while after the bike is warm enough afterwhile riding it for some time for some reason the clutch stopstops working properly, i have to stop and let it cool down otherwise i wont be able to ride.
 
I have changedUsually does this only when the oil and had changed the DOT 4, any other suggestions…bike is very warm, if i ride it for a few minutes it works fine,
I have changedUsually does this only when the oil and had changed the DOT 4, any other suggestions…bike is very warm, if i ride it for a few minutes it works fine,
 
Usually does this only whenI have changed the bike is very warm, if i ride it for a few minutes it works welloil and had changed the DOT 4, any other suggestions…
Usually does this only whenI have changed the bike is very warm, if i ride it for a few minutes it works welloil and had changed the DOT 4, any other suggestions…
 
Please help, thanks

Status:

open

Edit by: hidalgoerick ,

Text:

Hello.
 
myI have an Intruder 1400, year 2003 its given me clutch problems, it, and i am having problems with the clutch, it works pretty well for a while after the bike is warm enough after riding for some time for some reason the clutch stop working properly, i have to stop and let it cool down otherwise i wont be able to work properly againride.
myI have an Intruder 1400, year 2003 its given me clutch problems, it, and i am having problems with the clutch, it works pretty well for a while after the bike is warm enough after riding for some time for some reason the clutch stop working properly, i have to stop and let it cool down otherwise i wont be able to work properly againride.
 
I have changed the oil and had changed the DOT 4, any other suggestionssuggestions…
I have changed the oil and had changed the DOT 4, any other suggestionssuggestions…
 
pleaseUsually does this only when the bike is very warm, if i ride it for a few minutes it works well

Please
help, thanks
pleaseUsually does this only when the bike is very warm, if i ride it for a few minutes it works well

Please
help, thanks

Status:

open

Original post by: hidalgoerick ,

Text:

Hello.

my Intruder 1400, 2003 its given me  clutch problems, it works pretty well for a while after the bike is warm enough after riding for some reason the clutch stop working properly, i have to stop and let it cool to work properly again.

I have changed the oil and had changed the DOT 4, any other suggestions

please help, thanks

Status:

open