Skip to main content

Original post by: Philip Le Riche ,


I disassembled it again to take a closer look at the mechanism that drives this finger. I turned a few of the gears by hand to see what happened but it’s impossible (for a person of my modest intellect)  to see how it works. I tried powering it up with the control panel reconnected but the scanner still off in the hope of seeing the gears in action, but it flashed angry lights at me, and the status as seen by a connected computer said that something really bad had happened to my printer and I should take it to someone who could fix it. That’s me, so I put the scanner back, powered it up again and it was as docile as a lamb. So I tried a nozzle check. That worked, so I tried another. Still ok. I tried a head alignment and that worked too. Pushing my luck, I tried a single sheet duplex print, and it still hadn’t jammed up. So I put all the screws and panels back and reinstalled it where it lives, and we’ll see how it goes.

With luck, the problem might have been simply that the mechanism had got into an invalid state through pulling the plug without a soft power-off.

I wrote up the [guide|119426|disassembly] process as there aren’t many guides for printers.