Skip to main content

Fix Your Stuff

Right to Repair

Parts & Tools

Help

Current version by: jayeff (vote details) ,

Title:

ZTE Axon not opening properly

Text:

I have been using this phone for 1-2 years, and I just encountered this problem now.
 
Basically, the home button screen keeps flashing white, however I cannot open my phone using the power button on the side.
 
I tried tapping the home button in an attempt to open it. However nothing is opening.
 
Is there anyway to fix this?[br]
 
 
[br]
 
 
FYI, it’s the home button is still flashing a white circle of light.
 
=== Update (01/09/2019) ===
 
EDIT: I’m really sorry. I just had to hold the power button for a minute for my phone to reboot![br]
 
 
It’s back to normal.

Device:

ZTE Axon 7

Status:

openclosed
openclosed

Edit by: Kash Mone ,

Title:

ZTE Axon not opening properly

Text:

I have been using this phone for 1-2 years, and I just encountered this problem now.
 
Basically, the home button screen keeps flashing white, however I cannot open my phone using the power button on the side.
 
I tried tapping the home button in an attempt to open it. However nothing is opening.
 
Is there anyway to fix this?[br]
 
 
[br]
 
 
FYI, it’s the home button is still flashing a white circle of light.
 
=== Update (01/09/2019) ===
EDIT: I’m really sorry. I just had to hold the power button for a minute for my phone to reboot![br]
 
 
It’s back to normal.

Device:

ZTE Axon 7

Status:

open

Original post by: Kash Mone ,

Title:

ZTE Axon not opening properly

Text:

I have been using this phone for 1-2 years, and I just encountered this problem now.

Basically, the home button screen keeps flashing white, however I cannot open my phone using the power button on the side.

I tried tapping the home button in an attempt to open it. However nothing is opening.

Is there anyway to fix this?[br]

[br]

FYI, it’s the home button is still flashing a white circle of light.

Device:

ZTE Axon 7

Status:

open