Skip to main content
Help

Current version by: Mark Kelley ,

Text:

I had the same problem with my Coolpix camera: I could charge for a couple min, but then the light went to “fast blink” mode and stopped chargingcharging and “Battery Exhausted” mode. I thought it might be a bad battery…but.. WITH TWO DIFFERENT BATTERIES? That made no sense. I read through many on-line answers, none worked for me.
I had the same problem with my Coolpix camera: I could charge for a couple min, but then the light went to “fast blink” mode and stopped chargingcharging and “Battery Exhausted” mode. I thought it might be a bad battery…but.. WITH TWO DIFFERENT BATTERIES? That made no sense. I read through many on-line answers, none worked for me.
 
What worked for me was simply using a different transformer. The transformer I’d been using (apple white transformer) was too small: 5 V/2.1 amps (about 10 W) It would change the camera and then stop, and the light began fast blinking. I replaced it with a larger transformer : 5V/3.1A (about 15 W) and that workedworked fine. Problem solved. It was just that simple.
What worked for me was simply using a different transformer. The transformer I’d been using (apple white transformer) was too small: 5 V/2.1 amps (about 10 W) It would change the camera and then stop, and the light began fast blinking. I replaced it with a larger transformer : 5V/3.1A (about 15 W) and that workedworked fine. Problem solved. It was just that simple.

Status:

open

Edit by: Mark Kelley ,

Text:

I had the same problem with my Coolpix camera: I could charge for a couple min, but then the light went to “fast blink” mode and stopped charging. I thought it might be a bad batter…but..TWO OF THEMbattery…but.. WITH TWO DIFFERENT BATTERIES? That made no sense. I read through many on-line answers, none worked for me.
I had the same problem with my Coolpix camera: I could charge for a couple min, but then the light went to “fast blink” mode and stopped charging. I thought it might be a bad batter…but..TWO OF THEMbattery…but.. WITH TWO DIFFERENT BATTERIES? That made no sense. I read through many on-line answers, none worked for me.
 
What worked for me was simply using a different transformer. The transformer I’d been using (apple white transformer) was too small: 5 V/2.1 amps (about 10 W) It would change the camera and then stop, and the light began fast blinking. I replaced it with a larger transformer : 5V/3.1A (about 15 W) and that worked. It was just that simple.

Status:

open

Original post by: Mark Kelley ,

Text:

I had the same problem with my Coolpix camera: I could charge for a couple min, but then the light went to “fast blink” mode and stopped charging. I thought it might be a bad batter…but..TWO OF THEM? That made no sense. I  read through many on-line answers, none worked for me.

What worked for me was simply using a different transformer.  The transformer I’d been using (apple white transformer) was too small: 5 V/2.1 amps (about 10 W) It would change the camera and then stop, and the light began fast blinking.  I replaced it with a larger transformer : 5V/3.1A (about 15 W) and that worked. It was just that simple.

Status:

open