Skip to main content

Original post by: vanmaanen.marcelle.p ,


After  spending all day trying everything suggested again and again trackpad and keyboard are back!

When I connected external mouse and keyboard all worked, however when I opened up settings for trackpad it showed searching for Bluetooth with no options. Tried the resets all offered above, SMC and PRAM reset about 50 times. SMC light changed on power connector but no luck. I tried switching the Bluetooth off but then no trackpad recognised in settings at all.  Then shot compressed air over the keypad and trackpad, still didn’t work. Last resort hairdryer on cold setting and gave it a thorough blast all around trackpad and keyboard, SMC reset and bingo! I don’t know what worked, but something did- everything is back to normal and in setting I now have have the normal options for everything, point and click, scroll, and  more gestures, etc. The only thing I’d done differently prior to the problem was going into chrome settings last night and allowing pop ups, I disabled that with the external mouse and keyboard connected just prior to the hairdryer approach- and this may have helped -good luck, what a nuisance!