Skip to main content

Fix Your Stuff

Right to Repair



Original post by: Bonnie Baxter ,


This sort of thing just happened to me on an iPad 4 digitizer swap. I know the digitizer worked beautifully—right up

until the final reassembly. I tested it numerous times by dragging an icon all over the screen. And it was removed from a well-working iPad (that was on someone else’s account whom I can’t reach, so its usefulness was limited.) The digitizer worked well before removal, after motherboard swap…everything except the final step of sealing it up.

I took it back apart and re-seated the cable, but no good.

So I’m very interested to

any answers to Michael’s question, or the original. The most likely thing I can come up with is a very slightly damaged cable. I’ll test it with the broken glass digitizer next, if I can do so safely. It’s taped together and essentially intact. For that matter, I can also test it in the other iPad, to see whether I’ve caused a digitizer or motherboard problem…