Skip to main content
Help

Current version by: Albrecht Albers ,

Title:

What would cause my blender to not register its power supply?

Text:

It's a Ninja Mega Kitchen System blender, model BL770, used lightly over three years. Not a single hiccup. Except, this evening, when I plug it in and press the power button, the button doesn't light up, nor will the blender function. It's tried half a dozen power supplies throughout the house, but for some reason the power isn't going where it should go. I don't know if that means there's a loose connection inside the case, a short, or maybe the circuit control board decided to crap out on me.

Has anyone had this problem? Does anyone have an exploded diagram of the blender and electrical schematics? How do I go about ruling out possible causes?

Device:

Ninja Mega Kitchen System BL770

Status:

open

Accepted Answer:

525675

Original post by: Albrecht Albers ,

Title:

What would cause my blender to not register its power supply?

Text:

It's a Ninja Mega Kitchen System blender, model BL770, used lightly over three years. Not a single hiccup. Except, this evening, when I plug it in and press the power button, the button doesn't light up, nor will the blender function. It's tried half a dozen power supplies throughout the house, but for some reason the power isn't going where it should go. I don't know if that means there's a loose connection inside the case, a short, or maybe the circuit control board decided to crap out on me.

Has anyone had this problem? Does anyone have an exploded diagram of the blender and electrical schematics? How do I go about ruling out possible causes?

Device:

Ninja Mega Kitchen System BL770

Status:

open