Skip to main content
Help

Current version by: Nick and oldturkey03 (vote details) ,

Title:

Power / Startup Issue?

Text:

Greetings all,

I have a Lenovo ThinkPad T-420, and it appears to be in good condition. (I found it in my friend's garage and he said I could have it!) But even with a "good" working battery?...or plugged in with a "good" working power adapter it won't power on. its as if there's no power to the device even though there IS a good battery and power supply(and I know the battery and power supply are good because I have ANOTHER T-420 that they came from!) )Its not a bad looking laptop, and I would like to use it, but if its not working I don't know what to do next. Can anyone shed some light on this issue for me? Or is there someplace I ca ship it to be repaired?

Device:

ThinkPad T420

Status:

open

Accepted Answer:

+497562

Original post by: Eddie O'Connor ,

Title:

Power / Startup Issue?

Text:

Greetings all,

I have a Lenovo ThinkPad T-420, and it appears to be in good condition. (I found it in my friend's garage and he said I could have it!) But even with a "good" working battery?...or plugged in with a "good" working power adapter it won't power on. its as if there's no power to the device even though there IS a good battery and power supply(and I know the battery and power supply are good because I have ANOTHER T-420 that they came from!) )Its not a bad looking laptop, and I would like to use it, but if its not working I don't know what to do next. Can anyone shed some light on this issue for me? Or is there someplace I ca ship it to be repaired?

Device:

ThinkPad T420

Status:

open