Skip to main content
Help

Current version by: Ed W ,

Title:

Trimmer stalls and jerks like hitting something

Text:

Trimmer starts and runs fine, cuts well, but after several minutes will jerk and stall and it feels like you hit something. Will restart and run and will do it again...will do it multiple times during use . Filters clean, new plug, new fuel clean oil, and only use a jump start do not use the pull starter . It actually jerks hard and even when not cutting and just running it will do the same thing .This is my second Troy-bilt and both ran fine, first neone pull start broke and used jumperjump starter, it ran fine started doing what this one is doing, bought this one because other one not reliable , and now this one is doing the same thing , older one is a curved shaft this one a straight shaft...Help, gets frustrating while using .
Trimmer starts and runs fine, cuts well, but after several minutes will jerk and stall and it feels like you hit something. Will restart and run and will do it again...will do it multiple times during use . Filters clean, new plug, new fuel clean oil, and only use a jump start do not use the pull starter . It actually jerks hard and even when not cutting and just running it will do the same thing .This is my second Troy-bilt and both ran fine, first neone pull start broke and used jumperjump starter, it ran fine started doing what this one is doing, bought this one because other one not reliable , and now this one is doing the same thing , older one is a curved shaft this one a straight shaft...Help, gets frustrating while using .

Device:

Troy-Bilt TB675 EC

Status:

open

Original post by: Ed W ,

Title:

Trimmer stalls and jerks like hitting something

Text:

Trimmer starts and runs fine, cuts well, but after several minutes will jerk and stall and it feels like you hit something. Will restart and run and will do it again...will do it multiple times during use . Filters clean, new plug, new fuel  clean oil, and only use a jump start do not use the pull starter . It actually jerks hard and even when not cutting and just running it will do the same thing .This is my second Troy-bilt and both ran fine, first ne pull start broke and used jumper ran fine started doing what this one is doing, bought this one because other one not reliable , and now this one is doing the same thing , older one is a curved shaft this one a straight shaft...Help, gets frustrating while using .

Device:

Troy-Bilt TB675 EC

Status:

open