Skip to main content
Help

Current version by: Dan (vote details) ,

Title:

What causes “snowy” display on iMac screen after replacement

Text:

Completed the power supply replacement repair on a late 2012 27” iMac and at same time upgraded to SSD. Got display and everything sealed up and when I turn on I do get the boot chime, but what normally would be the grey loading screen is a grey snowy static with diagonal lines. No problem with logic board prior to this repair. Any suggestions on what happened? Possible that display cable did not fully click in and attach properly? Or could I have damaged the display cable during the repair? Please help!

[video|1162]

Device:

iMac Intel 27" EMC 2546

Status:

open

Accepted Answer:

+483228

Edit by: Greg Blair ,

Title:

What causes “snowy” display on iMac screen after replacement

Text:

Completed the power supply replacement repair on a late 2012 27” iMac and at same time upgraded to SSD. Got display and everything sealed up and when I turn on I do get the boot chime, but what normally would be the grey loading screen is a grey snowy static with diagonal lines. No problem with logic board prior to this repair. Any suggestions on what happened? Possible that display cable did not fully click in and attach properly? Or could I have damaged the display cable during the repair? Please help!
-[image|1428526]
+[video|1162]

Device:

iMac Intel 27" EMC 2546

Status:

open

Original post by: Greg Blair ,

Title:

What causes “snowy” display on iMac screen after replacement

Text:

Completed the power supply replacement repair on a late 2012 27” iMac and at same time upgraded to SSD. Got display and everything sealed up and when I turn on I do get the boot chime, but what normally would be the grey loading screen is a grey snowy static with diagonal lines. No problem with logic board prior to this repair. Any suggestions on what happened? Possible that display cable did not fully click in and attach properly? Or could I have damaged the display cable during the repair? Please help!

[image|1428526]

Device:

iMac Intel 27" EMC 2546

Status:

open