Skip to main content
Help

Current version by: John Dupont ,

Title:

-RAM not recognized after the system fell
+Ram not recognized after fall

Text:

My system is not recognizing both RAM memory modules anymore.
It initially had two 1GB RAM memory modules, which I replaced by two 2GB RAM memory modules, and everything worked fine for months.
It fell on the floor three weeks ago, and since then, the OS only recognizes 2 GB out of the 4. It always displays one slot as empty.
I have tried changing the configuration, keeping only one memory module, testing in both slots, etc, and couldn't draw a conclusion, because:
* With both memory modules, I got to a point where system was booting with only that memory module. Thus both memory module seems to work.
* With both slots, I got to a point where system was booting with a memory module only in that slot. Thus both slots seem to work.
* Conversely, while changing and re-testing some configurations I had already tested, I ended up having a configuration fail which had previously worked, with both memory modules and both slots.
I have tried the following:
+
* Reset SMC
* Reset PRAM
* Cleaned up RAM pins
* Loosen RAM socket screws
* Remove RAM socket screws
* Disconnect hard drive, and boot from USB
* Inserted 2mm plastic card in between both RAM memory modules
How to troubleshoot from then on ?

Device:

MacBook Pro 13" Unibody Mid 2009

Status:

open

Edit by: Dan ,

Title:

-Ram not recognized after fall
+RAM not recognized after the system fell

Text:

-My Macbook is not recognizing both RAM dims anymore.
+My system is not recognizing both RAM memory modules anymore.
-It initially had 2 1GB RAM dimms, which I replaced by 2 2GB RAM dimms, and everything worked fine for months.
+It initially had two 1GB RAM memory modules, which I replaced by two 2GB RAM memory modules, and everything worked fine for months.
-It fell on the floor three weeks ago, and since then, OS only recognizes 2 GB out of the 4. It always displays one slot as empty.
+It fell on the floor three weeks ago, and since then, the OS only recognizes 2 GB out of the 4. It always displays one slot as empty.
-I have tried changing the configuration, keeping only one dimm, testing in both slots, etc, and couldn't draw a conclusion, because:
+I have tried changing the configuration, keeping only one memory module, testing in both slots, etc, and couldn't draw a conclusion, because:
-- With both dimms, I got to a point where Macbook was booting with only that dimm. Thus both dimms seems to work
-
-- With both slots, I got to a point where Macbook was booting with a dimm only in that slot. Thus both slots seem to work
-
-- Conversely, while changing and re-testing some configurations I had already tested, I ended up having a configuration fail which had previously worked, with both dimms and both slots.
+* With both memory modules, I got to a point where system was booting with only that memory module. Thus both memory module seems to work.
+* With both slots, I got to a point where system was booting with a memory module only in that slot. Thus both slots seem to work.
+* Conversely, while changing and re-testing some configurations I had already tested, I ended up having a configuration fail which had previously worked, with both memory modules and both slots.
I have tried the following:
-
-- reset SMC
-
-- reset PRAM
-
-- clean up RAM pins
-
-- loosen RAM socket screws
-
-- remove RAM socket screws
-
-- disconnect hard drive, and boot from USB
-
-- insert 2mm plastic card in between both RAM dimms
+* Reset SMC
+* Reset PRAM
+* Cleaned up RAM pins
+* Loosen RAM socket screws
+* Remove RAM socket screws
+* Disconnect hard drive, and boot from USB
+* Inserted 2mm plastic card in between both RAM memory modules
How to troubleshoot from then on ?

Device:

MacBook Pro 13" Unibody Mid 2009

Status:

open

Original post by: John Dupont ,

Title:

Ram not recognized after fall

Text:

My Macbook is not recognizing both RAM dims anymore.

It initially had 2 1GB RAM dimms, which I replaced by 2 2GB RAM dimms, and everything worked fine for months.

It fell on the floor three weeks ago, and since then, OS only recognizes 2 GB out of the 4. It always displays one slot as empty.

I have tried changing the configuration, keeping only one dimm, testing in both slots, etc, and couldn't draw a conclusion, because:

- With both dimms, I got to a point where Macbook was booting with only that dimm. Thus both dimms seems to work

- With both slots, I got to a point where Macbook was booting with a dimm only in that slot. Thus both slots seem to work

- Conversely, while changing and re-testing some configurations I had already tested, I ended up having a configuration fail which had previously worked, with both dimms and both slots.

I have tried the following:

- reset SMC

- reset PRAM

- clean up RAM pins

- loosen RAM socket screws

- remove RAM socket screws

- disconnect hard drive, and boot from USB

- insert 2mm plastic card in between both RAM dimms

How to troubleshoot from then on ?

Device:

MacBook Pro 13" Unibody Mid 2009

Status:

open