Skip to main content
Help

Original post by: Ben ,

Text:

I had a similar problem with my iPhone 5c.  I wanted to restore it but I couldn't verify my Apple ID because the date and time was screwed up.  Tried all resets etc but it wouldn't get the date right.  When I read it might be a hardware issue, I tried a crazy solution I had with another 5c which surprisingly worked.

It involves heating up the iPhone with a hairdryer.  See the thread below to see the answer to my first issue:

[post|273755]

So I heated up the phone and tried adjust the date again.  At first nothing.  I tried toggling the automatic update a few times and then eventually it just keep spinning, not finding the right date but not finding the wrong one either.  So while that was happening I went back to iTunes and tried the restore phone function again and this time it didn't ask for an Apple ID verification (actually it had previously asked me to sign out) but just went straight into the restore.  I kept the hair dryer on during the whole process, some card holder taken out to assist, and it has restored perfectly.  I'm waiting for a new SIM card to test it completely but so far so good.

I can't say why it worked but I thought I'd share in case it works for someone else.  I had nothing to lose either way so I thought why not.

Status:

open