Skip to main content
Help

Current version by: oldturkey03 (vote details) ,

Title:

issues after battery replacement

Text:

I've had iphone for 2 years and replaced the battery.  Everything worked except camera when i put together so reopened and checked connection on back side of logic board.  The phone doesn't turn on now.  If I plug into wall charger the apple logo comes up for a few seconds and disappears.  If i plug into itunes i can get it into dfu mode but cannot restore (get error 1601).  The whole time it's plugged into itunes the screen is off.  I've disassembled and reassembled several times rechecking all the ribbon connections.  I've been very careful not to damage any of the ribbons or connectors.  Any suggestions would be appreciated.  Do the symptoms point toward any particular component if damage is the cause?

Device:

iPhone 3G

Status:

open

Accepted Answer:

45691

Original post by: Don ,

Title:

issues after battery replacement

Text:

I've had iphone for 2 years and replaced the battery.  Everything worked except camera when i put together so reopened and checked connection on back side of logic board.  The phone doesn't turn on now.  If I plug into wall charger the apple logo comes up for a few seconds and disappears.  If i plug into itunes i can get it into dfu mode but cannot restore (get error 1601).  The whole time it's plugged into itunes the screen is off.  I've disassembled and reassembled several times rechecking all the ribbon connections.  I've been very careful not to damage any of the ribbons or connectors.  Any suggestions would be appreciated.  Do the symptoms point toward any particular component if damage is the cause?

Device:

iPhone 3G

Status:

open