Skip to main content

Fix Your Stuff

Right to Repair



Original post by: Pete ,


***Solved*** for a Samsung Galaxy Tab 2   10.1 (GT-P5110) stuck in boot loop AND unable to enter ASR recovery mode.


1) Boots to white Samsung Tab 2 screen, and then through to coloured animated Samsung  logo where it then gets stuck and commences booting again. It will continue this cycle continuously. The tablet can not be forced off (holding power button down) unless the charger is connected. Battery was charged to 100% the entire time.

2) I could not enter the ASR (Android System Recovery) mode to try the other suggested options of clearing the cache or wiping the tablet back to factory settings . This is usually done by holding the power button and volume down button (Vol down is the one closest to the power button) simultaneously and releasing the power button when the white Samsung Galaxy Tab 2 10.1 logo comes up. The tablet is supposed to boot into the recovery menu but for me it just continued to the animated Samsung logo and then cycled again like before. It made no difference if it was charging or on battery. Power + volume up also didn't work.

I read lots about reloading firmware using ODIN and PIT and .tar files which were quite foreign to me.

**SOLUTION** I opened the case and disconnected the power connector to the battery for about 3 minutes. I tried to start the tablet but was still stuck in the boot loop cycle. However, this time, I could access the ASR (see point 2 above) successfully. ***NOTE the tablet MUST be running on battery only- charger disconnected***

I tried clearing the cache but no change. I then started the ASR again and selected Wipe Data/Factory reset. 2 minutes later it was wiped, and started normally.


This boot loop problem is very common it seems. Lots of people asking how to fix and I spent hours looking for a solution, most involving accessing the ASR recovery which I could not do or rooting/reloading firmware which I was reluctant to attempt.

I have lost all my files in the process but I have back-ups so fortunately no loss for me.

You may like to leave the battery disconnected for a longer time to allow full discharge of the electronics. 3 minutes worked for me but some suggest a few hours.