Skip to main content

Fix Your Stuff

Right to Repair

Store

Help

Current version by: mayer, rj713, and ABCellars (vote details) ,

Title:

MacBook unibody keyboard ribbon cable won't go in

Text:

It is only going in less than 1/16" and won't lock down.  I have tried a bit of tape for leverage, I have a good angle on it, it just won't go in.  I have the midwall off, and I have plenty of room, it just refuses to go in and lock. what am I doing wrong?  Thanks.

Device:

MacBook Unibody Model A1278

Status:

open

Accepted Answer:

44178

Edit by: boo ,

Title:

MacBook unibody keyboard ribbon cable won't go in

Text:

It is only going in about 1/8less than 1/16" and won't lock down. I have tried a bit of tape for leverage, I have a good angle on it, it just won't go in. I have the midwall off, and I have plenty of room, it just refuses to go in and lock. what am I doing wrong? Thanks.
It is only going in about 1/8less than 1/16" and won't lock down. I have tried a bit of tape for leverage, I have a good angle on it, it just won't go in. I have the midwall off, and I have plenty of room, it just refuses to go in and lock. what am I doing wrong? Thanks.

Device:

MacBook Unibody Model A1278

Status:

open

Edit by: boo ,

Title:

MacBook unibody keyboard ribbon cable won't go in

Text:

It is only going in about 1/8" and won't lock down. I have tried a bit of tape for leverage, I have a good angle on it, it just won't go in. whatI have the midwall off, and I have plenty of room, it just refuses to go in and lock. what am I doing wrong? Thanks.
It is only going in about 1/8" and won't lock down. I have tried a bit of tape for leverage, I have a good angle on it, it just won't go in. whatI have the midwall off, and I have plenty of room, it just refuses to go in and lock. what am I doing wrong? Thanks.

Device:

MacBook Unibody Model A1278

Status:

open

Original post by: boo ,

Title:

MacBook unibody keyboard ribbon cable won't go in

Text:

It is only going in about 1/8" and won't lock down.  I have tried a bit of tape for leverage, I have a good angle on it, it just won't go in.  what am I doing wrong?  Thanks.

Device:

MacBook Unibody Model A1278

Status:

open