Skip to main content
Help

Current version by: Bill Watkins ,

Title:

Battery or wiring seems fried by a power surge Bose Quietcomfort 20 ea

Text:

I had a perfectly good set of Bose Quietcomfort 20 ear buds, battery working well, charging quickly and lasting ages.
 
Whilst in Thailand and charging the battery there was an electrical storm and a power outage (presume surge).
 
When I tried to use the headphones there's no charge in the battery and it won't charge.
 
There's no noise reduction when I turn them on.
 
The green charging light comes on when they're plugged in but even then there's no noise reduction.
 
As soon as I unplug from the power the green light goes off and the battery is dead.
 
Any suggestions?
 
Thanks,
 
Bill [image|1242679]
Bill [image|1242679]

Device:

Bose QuietComfort 2

Status:

open

Edit by: Bill Watkins ,

Title:

Battery or wiring seems fried by a power surge Bose Quietcomfort 20 ea
Battery or wiring seems fried by a power surge Bose Quietcomfort 20 ea

Text:

I had a perfectly good set of Bose Quietcomfort 20 ear buds, battery working well, charging quickly and lasting ages.

Whilst in Thailand and charging the battery there was an electrical storm and a power outage (presume surge).

When I tried to use the headphones there's no charge in the battery and it won't charge.

There's no noise reduction when I turn them on.

The green charging light comes on when they're plugged in but even then there's no noise reduction.

As soon as I unplug from the power the green light goes off and the battery is dead.

Any suggestions?

Thanks,

Bill

Device:

Bose QuietComfort 2

Status:

open

Original post by: Bill Watkins ,

Title:

Battery or wiring seems fried by a power surge

Text:

I had a perfectly good set of Bose Quietcomfort 20 ear buds, battery working well, charging quickly and lasting ages.

Whilst in Thailand and charging the battery there was an electrical storm and a power outage (presume surge).

When I tried to use the headphones there's no charge in the battery and it won't charge.

There's no noise reduction when I turn them on.

The green charging light comes on when they're plugged in but even then there's no noise reduction.

As soon as I unplug from the power the green light goes off and the battery is dead.

Any suggestions?

Thanks,

Bill

Device:

Bose QuietComfort 2

Status:

open