Skip to main content
Help

Original post by: Duane ,

Text:

Thought I'd add my bit here.

Had the same issue, tried a different screen from what was installed (better quality) but same thing.

Hard reset - Same thing

Put a genuine screen on - works.

So installed all the small parts on the damaged genuine screen, fitted it, put in dfu mode and reset/updated to 11.02.

Removed the screen, done the usual replacement, and worked..... for 10 seconds.

Got into contact of the manufacturer i deal with, and hats off, they responded back promptly late into the evening, and was trying all sorts their end.

This is what they sent me:

"After upgraded the iPhone to iOS 11.0 (The touch not work) , our factory has tried many times with different methods with  different mobile phone this afternoon , and the solve method is upgrade your phone system to iOS 11.02 (Not 11.0 or 11.1) .

Also the testing details as below :

1. Upgrade to iOS 11.0 : Touch not work . We must replace original or refurbished LCD , then it is ok

2. Upgrade to iOS 11.01 : Touch not work . If we make Hard Reset , the touch would be work for few seconds or keep working to the screen power off . Then , the touch not work again and need to hard reset again .

3. Upgrade to iOS 11.02 : Touch work good .

So we suggest update to iOS 11.02 version ."

Done what they said for 11.02 which we a battery pull and power cycle as such, and it worked, until the phone woke up from sleeping.

Thus bit threw me off, as I was doing this with the after market screen which the phone originally had on, so swapped it over to the ones I buy off the manufacturer, done it again, and after sleeping/waking/powering off & on. It still works!

Hopefully this may help someone with this issue, because this was giving me a right headache, cancelled all other Repairs, and wasn't sure if my stock was effectively useless!

Status:

open