Skip to main content
Help

Current version by: Blake Klein ,

Title:

No backlight after repair - iPhone 6

Text:

I have an iPhone 6 come in that was liquid damaged, no backlight at all. All filters were fine but the FPC was black on the pins. Removed and replaced after reviving the pads. I get half backlight on the right hand side.
 
All filters have continuity and all pins have continuity to the filters. I have replaced all caps and filters, replaced the driver, the diode and the coil. I have reballed the driver from boards that had other problems and even the pins under the driver had continuity to the filters.
 
I found a tutorial here, could it be the issue: https://www.youtube.com/watch?v=R8BedLX7JAg[Removed as spam]
I found a tutorial here, could it be the issue: https://www.youtube.com/watch?v=R8BedLX7JAg[Removed as spam]
 
What's you experience?

Device:

iPhone 6

Status:

open

Accepted Answer:

429729

Edit by: oldturkey03 (vote details) ,

Title:

No backlight after repair - iPhone 6

Text:

I have an iPhone 6 come in that was liquid damaged, no backlight at all. All filters were fine but the FPC was black on the pins. Removed and replaced after reviving the pads. I get half backlight on the right hand side.

All filters have continuity and all pins have continuity to the filters. I have replaced all caps and filters, replaced the driver, the diode and the coil. I have reballed the driver from boards that had other problems and even the pins under the driver had continuity to the filters.

I found a tutorial here, could it be the issue: https://www.youtube.com/watch?v=R8BedLX7JAg

What's you experience?

Device:

iPhone 6

Status:

open

Accepted Answer:

429729

Original post by: Robert Stark ,

Title:

No backlight after repair - iPhone 6

Text:

I have an iPhone 6 come in that was liquid damaged, no backlight at all. All filters were fine but the FPC was black on the pins. Removed and replaced after reviving the pads. I get half backlight on the right hand side.

All filters have continuity and all pins have continuity to the filters. I have replaced all caps and filters, replaced the driver, the diode and the coil. I have reballed the driver from boards that had other problems and even the pins under the driver had continuity to the filters.

I found a tutorial here, could it be the issue: https://www.youtube.com/watch?v=R8BedLX7JAg

What's you experience?

Device:

iPhone 6

Status:

open