Skip to main content
Help

Current version by: Carlos Ferrari ,

Title:

External HDD not working when used as internal drive - 2011 iMac 27"

Text:

So this is the issue: I've got a 3tb StoreJet external drive and decided to install it inside my iMac after I upgraded the original drive to a SSD.
 
The SSD works and the DVD works but the HDD is not being recognised by Sierra even though it works fine when plugged with the external case - it does show up on Disk Utility but it asks me to reformat even though it works flawless when plugged as external.
 
I moved it back and forth a couple times to me sure and it does work when plugged in the external case but does not work when plugged inside the iMac.
 
Also the CPU fan went crazy and won't back down no matter what - tried PRAM reset, tried smcFanControl, tried SSDFanControl, nothing seems to quiet it down.
 
When I turn the iMac off then on again it stays quiet for about a minute, then it kicks in again full blast.
 
Checked all sensors, it's all plugged in correctly and the readings seems correct as well but the CPU fan will keep on going at 3800rpm even though the CPU reads only 30ºC.
 
Don't know if it's related to the HDD issue or if I f*cked up something on the logic board with all this back-and-forth due to the HDD issue :(
 
Any ideas?
Any ideas?
 
=== Update (08/26/2017) ===
 
After booting from Recovery Mode the CPU fan seems to be under control even though I've done nothing, just boot and restart.
 
The HDD still shows as 'partition damaged' if installed as internal drive, same thing if I use a different USB external bay but when plugged into the Transcend StoreJet USB external bay it works flawlessly.
 
Linux does the same thing which makes me wonder: is it a Unix thing that formats external drives as external only? This is VERY frustrating, I can't believe I'll have to buy another drive to use as internal then transfer all my files from this external one… ¬¬

Device:

Transcend StoreJet External HDD

Status:

open

Accepted Answer:

423818

Edit by: Carlos Ferrari ,

Title:

External HDD not working when used as internal drive - 2011 iMac 27"

Text:

So this is the issue: I've got a 3tb StoreJet external drive and decided to install it inside my iMac after I upgraded the original drive to a SSD.
 
The SSD works and the DVD works but the HDD is not being recognised by Sierra even though it works fine when plugged with the external case - it does show up on Disk Utility but it asks me to reformat even though it works flawless when plugged as external.
 
I moved it back and forth a couple times to me sure and it does work when plugged in the external case but does not work when plugged inside the iMac.
 
Also the CPU fan went crazy and won't back down no matter what - tried PRAM reset, tried smcFanControl, tried SSDFanControl, nothing seems to quiet it down.
 
When I turn the iMac off then on again it stays quiet for about a minute, then it kicks in again full blast.
 
Checked all sensors, it's all plugged in correctly and the readings seems correct as well but the CPU fan will keep on going at 3800rpm even though the CPU reads only 30ºC.
 
Don't know if it's related to the HDD issue or if I f*cked up something on the logic board with all this back-and-forth due to the HDD issue :(
 
Any ideas?

=== Update (08/26/2017) ===

After booting from Recovery Mode the CPU fan seems to be under control even though I've done nothing, just boot and restart.
The HDD still shows as 'partition damaged' if installed as internal drive, same thing if I use a different USB external bay but when plugged into the Transcend StoreJet USB external bay it works flawlessly.
Linux does the same thing which makes me wonder: is it a Unix thing that formats external drives as external only? This is VERY frustrating, I can't believe I'll have to buy another drive to use as internal then transfer all my files from this external one… ¬¬
Any ideas?

=== Update (08/26/2017) ===

After booting from Recovery Mode the CPU fan seems to be under control even though I've done nothing, just boot and restart.
The HDD still shows as 'partition damaged' if installed as internal drive, same thing if I use a different USB external bay but when plugged into the Transcend StoreJet USB external bay it works flawlessly.
Linux does the same thing which makes me wonder: is it a Unix thing that formats external drives as external only? This is VERY frustrating, I can't believe I'll have to buy another drive to use as internal then transfer all my files from this external one… ¬¬

Device:

Transcend StoreJet External HDD

Status:

open

Edit by: Carlos Ferrari ,

Title:

External HDD not working when used as internal drive - 2011 iMac 27"

Text:

So this is the issue: I've got a 3tb StoreJet external drive and decided to install it inside my iMac after I upgraded the original drive to a SSD.
 
The SSD works and the DVD works but the HDD is not being recognised by Sierra even though it works fine when plugged with the external case - it does show up on Disk Utility but it asks me to reformat even though it works flawless when plugged as external.
 
I moved it back and forth a couple times to me sure and it does work when plugged in the external case but does not work when plugged inside the iMac.
 
Also the CPU fan went crazy and won't back down no matter what - tried PRAM reset, tried smcFanControl, tried SSDFanControl, nothing seems to quiet it down.
When I turn the iMac off then on again it stays quiet for about a minute, then it kicks in again full blast.
 
Checked all sensors, it's all plugged in correctly and the readings seems correct as well but the CPU fan will keep on going at 3800rpm even though the CPU reads only 30ºC.
 
Don't know if it's related to the HDD issue or if I f*cked up something on the logic board with all this back-and-forth due to the HDD issue :(
Don't know if it's related to the HDD issue or if I f*cked up something on the logic board with all this back-and-forth due to the HDD issue :(
 
Any ideas?

Device:

Transcend StoreJet External HDD

Status:

open

Edit by: Carlos Ferrari ,

Title:

External HDD not working when used as internal drive - 2011 iMac 27"

Text:

So this is the issue: I've got a 3tb StoreJet external drive and decided to install it inside my iMac after I upgraded the original drive to a SSD.
 
The SSD works and the DVD works but the HDD is not being recognised by Sierra even though it works fine when plugged with the external case - it does show up on Disk Utility but it asks me to reformat even though it works flawless when plugged as external.
 
I moved it back and forth a couple times to me sure and it does work when plugged in the external case but does not work when plugged inside the iMac.
 
Also the CPU fan went crazy and won't back down no matter what - tried PRAM reset, tried smcFanControl, tried SSDFanControl, nothing seems to quiet it down.
 
Checked all sensors, it's all plugged in correctly and the readings seems correct as well but the CPU fan will keep on going at 3800rpm even though the CPU reads only 30ºC.
 
Don't know if it's related to the HDD issue or if I f*cked up something on the logic board with all this back-and-forth due to the HDD issue :(

Any ideas?
Don't know if it's related to the HDD issue or if I f*cked up something on the logic board with all this back-and-forth due to the HDD issue :(

Any ideas?

Device:

Transcend StoreJet External HDD

Status:

open

Edit by: Carlos Ferrari ,

Title:

External HDD not working when used as internal drive - 2011 iMac 27"

Text:

So this is the issue: I've got a 3tb StoreJet external drive and decided to install it inside my iMac after I upgraded the original drive to a SSD.
 
The SSD works and the DVD works but the HDD is not being recognised by Sierra even though it works fine when plugged with the external case - it does show up on Disk Utility but it asks me to reformat even though it works flawless when plugged as external.
I
moved it back and forth a couple times to me sure and it does work when plugged in the external case but does not work when plugged inside the iMac.

It does show up on Disk Utility but it asks me to reformat even though it works fine when plugged as external.
The SSD works and the DVD works but the HDD is not being recognised by Sierra even though it works fine when plugged with the external case - it does show up on Disk Utility but it asks me to reformat even though it works flawless when plugged as external.
I
moved it back and forth a couple times to me sure and it does work when plugged in the external case but does not work when plugged inside the iMac.

It does show up on Disk Utility but it asks me to reformat even though it works fine when plugged as external.
 
Also the CPU fan went crazy and won't back down no matter what - tried PRAM reset, tried smcFanControl, tried SSDFanControl, nothing seems to quiet it down.
 
Checked all sensors, it's all plugged in correctly and the readings areseems correct as well but the CPU fan will keep on going at 3800rpm even though the CPU reads 29ºConly 30ºC.
Checked all sensors, it's all plugged in correctly and the readings areseems correct as well but the CPU fan will keep on going at 3800rpm even though the CPU reads 29ºConly 30ºC.
 
Don't know if it's related to the HDD issue or if I f*cked up something withon the logic board with all this back-and-forth due to the HDD issue :(
Don't know if it's related to the HDD issue or if I f*cked up something withon the logic board with all this back-and-forth due to the HDD issue :(

Device:

Transcend StoreJet External HDD

Status:

open

Original post by: Carlos Ferrari ,

Title:

External HDD not working when used as internal drive - 2011 iMac 27"

Text:

So this is the issue: I've got a 3tb StoreJet external drive and decided to install it inside my iMac after I upgraded the original drive to a SSD.

The SSD works and the DVD works but the HDD is not being recognised by Sierra even though it works fine when plugged with the external case - moved it back and forth a couple times to me sure and it does work when plugged in the external case but does not work when plugged inside the iMac.

It does show up on Disk Utility but it asks me to reformat even though it works fine when plugged as external.

Also the CPU fan went crazy and won't back down no matter what - tried PRAM reset, tried smcFanControl, tried SSDFanControl, nothing seems to quiet it down.

Checked all sensors, it's all plugged in correctly and the readings are correct as well but the CPU fan will keep on going at 3800rpm even though the CPU reads 29ºC.

Don't know if it's related to the HDD issue or if I f*cked up something with the logic board with all this back-and-forth due to the HDD issue :(

Device:

Transcend StoreJet External HDD

Status:

open