Skip to main content
Help

Current version by: oldturkey03 ,

Text:

@jakekealyyy first thing you want to do is to check your battery. It may charge but may not hold that charge when you turn on the camera. After that you need to check the battery contacts, make sure they are not corroded , bend or otherwise damaged. Always make sure that the battery compartment closes properly and that there is nothing obstructing the contacts. It is of course possible that you are having issues with the power button/flex or the DC/DC board. For that you need a voltmeter and will have to disassemble your camera. Check the voltage according to the block diagram
@jakekealyyy first thing you want to do is to check your battery. It may charge but may not hold that charge when you turn on the camera. After that you need to check the battery contacts, make sure they are not corroded , bend or otherwise damaged. Always make sure that the battery compartment closes properly and that there is nothing obstructing the contacts. It is of course possible that you are having issues with the power button/flex or the DC/DC board. For that you need a voltmeter and will have to disassemble your camera. Check the voltage according to the block diagram
 
[image|1167181]

Status:

open

Edit by: oldturkey03 ,

Text:

@jakekealyyy first thing you want to do is to check your battery. It may chargercharge but may not hold that charge when you turn on the camera. After that you need to check the battery contacts, make sure they are not corroded , bend or otherwise damaged. It is of course possible that you are having issues with the power button/flex or the DC/DC board. For that you need a voltmeter and will have to disassemble your camera. Check the voltage according to the block diagram
@jakekealyyy first thing you want to do is to check your battery. It may chargercharge but may not hold that charge when you turn on the camera. After that you need to check the battery contacts, make sure they are not corroded , bend or otherwise damaged. It is of course possible that you are having issues with the power button/flex or the DC/DC board. For that you need a voltmeter and will have to disassemble your camera. Check the voltage according to the block diagram
 
[image|1167181]

Status:

open

Original post by: oldturkey03 ,

Text:

@jakekealyyy first thing you want to do is to check your battery. It may charger but may not hold that charge when you turn on the camera. After that you need to check the battery contacts, make sure they are not corroded , bend or otherwise damaged. It is of course possible that you are having issues with the power button/flex or the DC/DC board. For that you need a voltmeter and will have to disassemble your camera. Check the voltage according to the block diagram

[image|1167181]

Status:

open