Skip to main content
Help

Current version by: Hesham Adwan ,

Title:

nothing appear on screen , tried to replace the screen and still same

Text:

Hello
 
i got a galaxy s4 which is not turning on
 
i plugged the power supply to check if the motherboard is working , and i got a sign of Amperes meter of 0.25 and varying, which mean the motherboard is ok but the screen was not showing anything
i plugged the power supply to check if the motherboard is working , and i got a sign of Amperes meter of 0.25 and varying, which mean the motherboard is ok but the screen was not showing anything
 
then i tried to see if the problem were the cables , but they were fine , none of the copper terminals of the cable was damaged
 
after that i tried to replace the screen , but still the same problem , its not showing anything
 
is my method of checking is right ?
 
and what could be the problem now , did i miss somtihng ?
 
please help me to fix it
 
thanks

Device:

Samsung Galaxy S4

Status:

open

Edit by: Hesham Adwan ,

Title:

nothing appear on screen , tried to replace the screen and still same

Text:

Hello
 
i got a galaxy s4 which is not turning on
 
i plugged the power supply to check if the motherboard is working , and i got a sign of Amperes meter of 0.25 which mean the motherboard is ok but the screen was not showing anything
 
then i tried to see if the problem were the cables , but they were fine , none of the copper terminals of the cable was damaged
 
after that i tried to replace the screen , but still the same problem , its not turning onshowing anything
after that i tried to replace the screen , but still the same problem , its not turning onshowing anything
 
is my method of checking is right ?
 
and what could be the problem now , did i miss somtihng ?
 
please help me to fix it
 
thanks

Device:

Samsung Galaxy S4

Status:

open

Original post by: Hesham Adwan ,

Title:

nothing appear on screen , tried to replace the screen and still same

Text:

Hello

i got a galaxy s4 which is not turning on

i plugged the power supply to check if the motherboard is working , and i got a sign of Amperes meter of 0.25  which mean the motherboard is ok but the screen was not showing anything

then i tried to see if the problem were the cables , but they were fine , none of the copper terminals of the cable was damaged

after that i tried to replace the screen , but still the same problem , its not turning on

is my method of checking is right ?

and what could be the problem now , did i miss somtihng ?

please help me to fix it

thanks

Device:

Samsung Galaxy S4

Status:

open