Skip to main content
Help

Current version by: oldturkey03 (vote details) ,

Title:

water damage, phone is bootlooping but can get to recovery mode. fix?

Text:

put phone through laundry for 15 minutes in sleep mode.

dried it out in rice, got pentalobe screwdriver the next day, opened it up,

....skip ahead, put logic board in sonic bath of 99 or 100% alcohol for awhile. (i dont have a hot air rework station to open up the logic board metal shields)

before I was getting weird colored lines on the display. after the logic board sonic bath and opening the display to dry out/clean with alcohol, it at least showed an apple logo, and i could get it to itunes recovery mode, but when I unplug it from a wall and plug it into a computer, it shuts off completely.

took out the battery, same issue

bought a replacement battery.

installed it. still having that same issue. Apple logo keeps repeating when plugged into a wall. I can put it into iTunes recovery mode, but when i unplug it from the wall and try it on a laptop, (laptop is plugged in) it shuts off.

phone doesn't show apple logo or light up at all when plugged into laptop.

thoughts? is this a charge port issue? what else can i try?

do i need to open up the logic board shields?

thanks! I have a month of photos i'd like to salvage.  but i'd be fine if i could factory reset it too.

Device:

iPhone 6

Status:

open

Accepted Answer:

371416

Original post by: craig ,

Title:

water damage, phone is bootlooping but can get to recovery mode. fix?

Text:

put phone through laundry for 15 minutes in sleep mode.

dried it out in rice, got pentalobe screwdriver the next day, opened it up,

....skip ahead, put logic board in sonic bath of 99 or 100% alcohol for awhile. (i dont have a hot air rework station to open up the logic board metal shields)

before I was getting weird colored lines on the display. after the logic board sonic bath and opening the display to dry out/clean with alcohol, it at least showed an apple logo, and i could get it to itunes recovery mode, but when I unplug it from a wall and plug it into a computer, it shuts off completely.

took out the battery, same issue

bought a replacement battery.

installed it. still having that same issue. Apple logo keeps repeating when plugged into a wall. I can put it into iTunes recovery mode, but when i unplug it from the wall and try it on a laptop, (laptop is plugged in) it shuts off.

phone doesn't show apple logo or light up at all when plugged into laptop.

thoughts? is this a charge port issue? what else can i try?

do i need to open up the logic board shields?

thanks! I have a month of photos i'd like to salvage.  but i'd be fine if i could factory reset it too.

Device:

iPhone 6

Status:

open