Skip to main content
Help

Current version by: ab301wolves ,

Title:

N64 Turns on but no sound or picture

Text:

I've had this N64 for about 20 years now, and I pulled it out of storage three days ago, hooked it up to my TV, put in a cartridge, and it worked just fine. I recently bought a new controller off of Amazon (made by Cirka) and some more games. I hooked the N64 back up to my TV today, plugged in my original Nintendo brand controller and the new Cirka controller,  turned it on, but no picture or sound. The red light turns on but no signal on my TV. I have tried hooking it up to other TVs around my house as well.. but nothing. I originally thought the AV cable was the problem, but it looks fine. Any suggestions?

Device:

Nintendo 64

Status:

open

Accepted Answer:

356390

Edit by: ab301wolves ,

Title:

TurnsN64 Turns on but no sound or picture
TurnsN64 Turns on but no sound or picture

Text:

I've had this N64 for about 20 years now, and I pulled it out of storage three days ago, hooked it up to my TV, put in a cartridge, and it worked just fine. I recently bought a new controller off of Amazon (made by Cirka) and some more games. I hooked the N64 back up to my TV today, plugged in my original Nintendo brand controller and the new Cirka controller,  turned it on, but no picture or sound. The red light turns on but no signal on my TV. I have tried hooking it up to other TVs around my house as well.. but nothing. I originally thought the AV cable was the problem, but it looks fine. Any suggestions?

Device:

Nintendo 64

Status:

open

Original post by: ab301wolves ,

Title:

Turns on but no sound or picture

Text:

I've had this N64 for about 20 years now, and I pulled it out of storage three days ago, hooked it up to my TV, put in a cartridge, and it worked just fine. I recently bought a new controller off of Amazon (made by Cirka) and some more games. I hooked the N64 back up to my TV today, plugged in my original Nintendo brand controller and the new Cirka controller,  turned it on, but no picture or sound. The red light turns on but no signal on my TV. I have tried hooking it up to other TVs around my house as well.. but nothing. I originally thought the AV cable was the problem, but it looks fine. Any suggestions?

Device:

Nintendo 64

Status:

open