Skip to main content
Help

Original post by: Carol Gonzales ,

Text:

Luckily I kept the K-Cup cleaner which was recommended here to be used to clean the needle.  I have only used bottled water in this machine and have had it less than 3 weeks when this message showed up for the first time.  Well, I thought today was the first time, but the husband told me it happened to him once before.  I went to the Keurig web site first and there's NO mention of this problem.  Googled it & thankfully it brought me here.  I used the orange K-Cup needle cleaner thingy which I saved and thankfully knew right where I put it.  It says to turn off the machine first.  Fill the needle cleaner device (the clear part of the orange thingy) with water. Then put in the orange needle cleaner with the arrows pointing down and close the lid as you would when loading a K-Cup.  Again, machine is OFF at this point.  Directions said open and shut the lid 5 times.  Then remove the orange K-Cup needle cleaning device and plug your machine power back in.  After allowing the device to reheat,  raise and lower the K-Cup handle again but WITHOUT any K-Cup like you would if you were just wanting hot water.  Run 12 oz of hot water into a mug and you should see lots of grinds and dirt come through into your cup.  After I did all this, the Keurig brewed just fine.  I'm hopeful we don't ever get to the point where the brewer just decides to not work again as this does seem like a terrible design flaw.  I had a Rivo from Keurig and only purchased this K-Cup brewer because the Rivo pods are being phased out along with their  Rivo brewer.  In fact, there were a few weeks where I couldn't even get ANY Rivo pods from Keurig at all.  I don't know what the deal is with this company....but it seems like they should at least let people know up front of the maintenance requirements.  Being completely transparent would be better than making people figure it out on their own or after being very frustrated when you suddenly can't get any coffee.

Status:

open