Help

Original post by: Jenni Williams Spence ,

Title:

Can I recover data after Errno = 19?

Text:

Hi there,

I have an early 2011 MacBook Pro (lost track of the exact operating system version, but it was Yosemite) that froze last night to the point where I had to do a hard shutdown. When I turned it back on, it failed to load and I got the grey screen with the no entry symbol.

I tried booting it into recovery mode and running the disk utility to verify the Mac internal HD and got the following messages: 'This volume could not be verified completely' and 'Error: This disk needs to be repaired. Click repair disk'. Unfortunately the option to repair the disk was ghosted out. I noted that it said the HD was 'not mounted' but attempts to mount it failed.

I also tried booting from the original install disk, in case using the disk utility from there made any difference, but it kept just booting the standard way (even though the disk was inserted and I was holding down C). I tried holding down the option key while I started up to see if I could select the install disk, but it only gave me the option of the Mac HD. I know I've successfully booted from the install disk when I was verifying the hard drive prior to upgrading to Yosemite.

I next tried to boot in safe mode using the Verbose mode, but didn't get very far. It came up with the text 'cannot mount root, errno = 19', and kept repeating.

I also tried to reset the NVRAM and SMC just in case, but this didn't make any difference.

I know it sounds like it is most likely that the hard drive has done it's dash. Unfortunately I haven't backed up for a few days and there are a few critical work files I would like to recover, if at all possible, which leaves me with the following questions...

- Is there anything else I should do, or should I bother taking it to an apple or Mac repair store?

- What do you think is the exact issue, given the errno = 19 message, and the inability to boot from the install disk?

- With this type of error, is there any chance that target disk mode would work so that I could recover those files?

- Are there any other options for trying to recover some data?

Any and all advice would be greatly appreciated. Thank you!

Device:

MacBook Pro 13" Unibody Early 2011

Status:

open