Skip to main content
Help

Current version by: oldturkey03 ,

Title:

jump start power station will not hold its charge when pluged in

Text:

ok when i plug the box in it will not take the charge i have the knob turned in the off
 
there is one of those surge things in the back of it and tryed pushing it but nothing
 
ahh i have the box open and now i am trying one thing with my batter charger i am
 
trying to give it a charge thru putting a charge in to the cables that give the jump to the car batter if you under stand i hope you do . but i bought it like it was i just thought i can fix it so if you can think of any possibles my E - mail is

ziggie_man19967@yahoo.com thanks
thanks charles
trying to give it a charge thru putting a charge in to the cables that give the jump to the car batter if you under stand i hope you do . but i bought it like it was i just thought i can fix it so if you can think of any possibles my E - mail is

ziggie_man19967@yahoo.com thanks
thanks charles

Device:

Jump Starter Power Station

Status:

open

Original post by: ziggieman19967 ,

Title:

jump start power station will not hold its charge when pluged in

Text:

ok  when i plug the box in it will not take the charge i have the knob turned in the off

there is one of those surge things in the back of it  and tryed pushing it  but nothing

ahh  i have the box open and now i am trying  one thing with my batter charger i am

trying to give it a charge thru  putting a charge in to the  cables that give the jump to the car batter if you under stand i hope you do .  but i bought  it like it was i just thought i can fix it so  if you can think of any possibles  my E - mail is

ziggie_man19967@yahoo.com   thanks charles

Device:

Jump Starter Power Station

Status:

open