Skip to main content

Fix Your Stuff

Right to Repair

Parts & Tools

Help

Original post by: teardropdm ,

Text:

i had this same problem on 2 different tab s2's here is what i figured out......

the trick i found out is to not put your tablet in power save mode, my buddy had his in power save mode and the touch would not be responsive after we locked the screen, so we exchanged it (of course we didnt know this was the issue at 1st) and got a new one and did the same thing, initially reading on here and trying all these other "Solutions" i thought it was apps he was installing.. deleted those and nothing...so i see his tablet is in Power Save Mode and i turn it off...and WALA!!!! it worked, no problems with it now it works fine....i mean we have a volume down key issue but its not too too big of a deal... but i really hope this helps you guys, i was really annoyed with customer service, they didnt help at all, they just pointed me to a sevice technition in my area, and they will charge you, i forwarded this info to thier head of quality control with my info hopefully they can get back to me to help the later versions with this problem, its a very nice and amazing tablet when its working :)

Status:

open