Skip to main content
Help

Current version by: mayer (vote details) ,

Title:

Odd power issues (help!)

Text:

I have a GE side-by-side refrigerator from 2007 that worked great for a year 1/2. After a move. I plugged it in and the internal lights came on but no fan, compressor, ice maker, or control panel LEDs.  I thought it was dead and forgot to unplug it, but after ~ 72hrs it was working fine and did so for another 8-10 months. Then we had a power outage and the same thing happened. Again after a few days it started again.  By this time I had to get a new one because I didn't know if or when it start up.  But I kept it cos it was in perfect shape. AGAIN, the power was dropped but this time it never came back on. Left it plugged in for two months.

I'm a DIY. Worked on many appliances with intuctctons. So I'm not afraid of dismantling it or work. Because at this point i can't brake it!  So it's fix it or dump it!

Device:

Refrigerator

Status:

open

Accepted Answer:

347040

Edit by: Sam Goldheart ,

Title:

Odd power issues (help!)

Text:

I have a GE side-by-side refrigerator from 2007 that worked great for a year 1/2. After a move. I plugged it in and the internal lights came on but no fan, compressor, ice maker, or control panel LEDs.  I thought it was dead and forgot to unplug it, but after ~ 72hrs it was working fine and did so for another 8-10 months. Then we had a power outage and the same thing happened. Again after a few days it started again.  By this time I had to get a new one because I didn't know if or when it start up.  But I kept it cos it was in perfect shape. AGAIN, the power was dropped but this time it never came back on. Left it plugged in for two months.

I'm a DIY. Worked on many appliances with intuctctons. So I'm not afraid of dismantling it or work. Because at this point i can't brake it!  So it's fix it or dump it!

Device:

GE RefrigeratorRefrigerator
GE RefrigeratorRefrigerator

Status:

open

Original post by: Jacob ,

Title:

Odd power issues (help!)

Text:

I have a GE side-by-side refrigerator from 2007 that worked great for a year 1/2. After a move. I plugged it in and the internal lights came on but no fan, compressor, ice maker, or control panel LEDs.  I thought it was dead and forgot to unplug it, but after ~ 72hrs it was working fine and did so for another 8-10 months. Then we had a power outage and the same thing happened. Again after a few days it started again.  By this time I had to get a new one because I didn't know if or when it start up.  But I kept it cos it was in perfect shape. AGAIN, the power was dropped but this time it never came back on. Left it plugged in for two months.

I'm a DIY. Worked on many appliances with intuctctons. So I'm not afraid of dismantling it or work. Because at this point i can't brake it!  So it's fix it or dump it!

Device:

GE Refrigerator

Status:

open