Skip to main content
Help

Original post by: Jim ,

Text:

I had to add to this.

I bought a google nexus 7 in 2014 through Staples, although it was manufactured in 2013.

I had the same problem.....plug in charger, after a few seconds there is a short duration slight white flicker on the screen (you'll see this much easier in the dark, trust me), and then back to black and nothing, no charging, nothing.

I tried the battery connector removal/reinstall thing....no help. The connector was not loose and the battery was very secure.

I tried different chargers besides the one that came from Asus, plugging into my computer USB port, holding down the power and volume down after plugging in, while plugging in, switched to power and volume up, etc.

The last thing that I did was to plug into the USB on computer and repeatedly plug in and pull the plug out. Then I noticed that I didn't even get the aforementioned flicker!!! I thought that I made it worse!

Next I plugged it back into the kodak ac to USB supply that I had been using and still no flicker!

Then I pressed in the power switch and there it was.....the beautiful Google displayed.

All of this took a lot of time....if I were to add up all the time, I would say 2-3 hours....yours may take less or more time, of course.

I think that my story to tell is that you have to keep trying different things as were mentioned here (although I think that the connected of power directly to the battery connector would be a last resort, if that, as that is risky) until you get the unit to boot, and then show 0% charged and then shut down, and then show the charging symbol, and eventually charge.

Be persistent with trying different things at different times, etc until you get it!!!

One other thing. I don't think that the battery connector is loose if you get the aforementioned flicker on turn on, so don't pry off the back cover if you don't have to.

I really hope that this helps.

Status:

open