Skip to main content
Help

Original post by: Alexandre Rodrigues ,

Text:

I guys,

I'm facing intermitent issues with the usb ports at may toshiba satellite pro c650 with Windows 8.1 Pro x64. It happens when i pluged an usb stick and suddently all usb ports went down.

The laptop only has 2 usb ports: one where i connect the wireless mouse and another to connect usb sticks, disks and other usb stuffs.

I went to a repair shop and i was told that the laptop needs to replace the motherboard because the usb ports are integrated. That's a thing i'm considering...

I followed the steps described by Allan Richardson, by unistalling all usb roots at Device Manager. Then i closed the laptop and waited for a few minutes.

After that i pressed the power botton and waited for the complete boot, entered the session password and then pluged the usb mouse receiver. All went well. After a few minutes, the usb port stoped to work again.

I repeted the steps for a few times and all went as described before. The I stoped to uninstall the usb roots because every time i reboot the usb mouse receiver is recognised and work for a few minutes. But if i connect any other device in the other usb port, they stop to work immediatly.

Following other instructions, i don't remember where (probably here), i went to the properties of each usb roots and disabled all options at Power Management as the mouse worked for about one hour, then stoped agains (by the way, just when i writing this).

By disabling all options of the usb root properties could help someone!

Alex

Status:

open