Skip to main content
Help

Current version by: Jacob ,

Title:

iMac won't power on, no LEDs blinking

Text:

Hi there,

our 2428 iMac had some strange behaviour until it got worse:

Some day, after disconnecting the power cord (after shutting down), the mac didn't turn on again. No fans spinning, nothing.

Leaving it disconnected for ~24h would helped and it started.

Any apple authorized service worker couldn't help / identify the problem.

Also a buzzing sound appeared (don't know if this one is maybe related to the power-on-problem).

Now, after disconnecting the device again after months of using, it won't power on - even after waiting those 24h...I opened the imac to look at the diagnostic leds, connected the power cord and tried to power on several times...none of the four leds were blinking. I also tried another power cord and the SMC reset. It did not help ):.

1. I removed the whole display, i.e. '''I removed all cables connected to the display (could this also led to the diagnostic leds not working?''')

If I move really close to the psu, I can hear two clicking sounds alternating..one is louder than the other.

2. What more could I try to diagnose the problem? (Maybe I missed something?)

3. Could the coin cell or any other part be the problem?

4. Also, I have a question about the psu apple part number. It's the ADP-200DFB. What's the difference to the  661-5299 or 614-0444 which I can buy here on ifixit?

5. And finally, why are those parts so expensive? I mean >130$ for a psu? It's nothing special, is it?

Thank you very, very much :)

Kind regards

Device:

iMac Intel 21.5" EMC 2428

Status:

open

Accepted Answer:

221666

Edit by: Jacob ,

Title:

iMac won't power on, no LEDs blinking

Text:

Hi there,
 
our 2428 iMac had some strange behaviour until it got worse:
 
Some day, after disconnecting the power cord (after shutting down), the mac didn't turn on again. No fans spinning, nothing.
 
Leaving it disconnected for ~24h would helped and it started.
 
Any apple authorized service worker couldn't help / identify the problem.
 
Also a buzzing sound appeared (don't know if this one is maybe related to the power-on-problem).
 
Now, after disconnecting the device again after months of using, it won't power on - even after waiting those 24h...I opened the imac to look at the diagnostic leds, connected the power cord and tried to power on several times...none of the four leds were blinking. I also tried another power cord and the SMC reset. It did not help ):.
 
1. I removed the whole display, i.e. '''I removed all cables connected to the display (could this also led to the diagnostic leds not working?''')
 
If I move really close to the psu, I can hear two clicking sounds alternating..one is louder than the other.
 
2. What more could I try to diagnose the problem? (Maybe I missed something?)
 
3. Could the coin cell or any other part be the problem?
 
4. Also, I have a question about the psu apple part number. It's the ADP-200DFB. What's the difference to the 661-5299 or 614-0444 which I can buy here on ifixit?
 
5. And finally, why are those parts so expensive? I mean >130$ for a psu? It's just a crappy psu, shouldn't be anynothing special, shouldis it?
5. And finally, why are those parts so expensive? I mean >130$ for a psu? It's just a crappy psu, shouldn't be anynothing special, shouldis it?
 
Thank you very, very much :)
 
Kind regards

Device:

iMac Intel 21.5" EMC 2428

Status:

open

Edit by: Jacob ,

Title:

iMac won't power on, no LEDs blinking

Text:

Hi there,
 
our 2428 iMac had some strange behaviour until it got worse:
 
Some day, after disconnecting the power cord (after shutting down), the mac didn't turn on again. No fans spinning, nothing.
 
Leaving it disconnected for ~24h would helped and it started.
 
Any apple authorized service worker couldn't help / identify the problem.
 
Also a buzzing sound appeared (don't know if this one is maybe related to the power-on-problem).
 
Now, after disconnecting the device again after months of using, it won't power on - even after waiting those 24h...I opened the imac to look at the diagnostic leds, connected the power cord and tried to power on several times...none of the four leds were blinking. I also tried another power cord and the SMC reset. It did not help ):.
Now, after disconnecting the device again after months of using, it won't power on - even after waiting those 24h...I opened the imac to look at the diagnostic leds, connected the power cord and tried to power on several times...none of the four leds were blinking. I also tried another power cord and the SMC reset. It did not help ):.
 
1. I removed the whole display, i.e. I'''I removed all cables connected to the display (could this also led to the diagnostic leds not working?working?''')
1. I removed the whole display, i.e. I'''I removed all cables connected to the display (could this also led to the diagnostic leds not working?working?''')
 
If I move really close to the psu, I can hear two clicking sounds alternating..one is louder than the other.
 
2. What more could I try to diagnose the problem? (Maybe I missed something?)
 
3. Could the coin cell or any other part be the problem?
 
4. Also, I have a question about the psu apple part number. It's the ADP-200DFB. What's the difference to the 661-5299 or 614-0444 which I can buy here on ifixit?
 
5. And finally, why are those parts so expensive? I mean >130$ for a psu? It's just a crappy psu, shouldn't be any special, should it?
 
Thank you very, very much :)
 
Kind regards

Device:

iMac Intel 21.5" EMC 2428

Status:

open

Edit by: Jacob ,

Title:

iMac won't power on, no LEDs blinking

Text:

Hi there,
 
our 2428 iMac had some strange behaviour until it got worse:
 
Some day, after disconnecting the power cord (after shutting down), the mac didn't turn on again. No fans spinning, nothing.
 
Leaving it disconnected for ~24h would helped and it started.
 
Any apple authorized service worker couldn't help / identify the problem.
 
Also a buzzing sound appeared (don't know if this one is maybe related to the power-on-problem).
 
Now, after disconnecting the device again after months of using, it won't power on - even after waiting those 24h...I opened the imac to look at the diagnostic leds, connected the power cord and tried to power on several times...none of the four leds were blinking. I also tried another power cord and the SMC reset. It did not help ):.

1. I removed the whole display, i.e. I removed all cables connected to the display (could this also led to the diagnostic leds not working?)
Now, after disconnecting the device again after months of using, it won't power on - even after waiting those 24h...I opened the imac to look at the diagnostic leds, connected the power cord and tried to power on several times...none of the four leds were blinking. I also tried another power cord and the SMC reset. It did not help ):.

1. I removed the whole display, i.e. I removed all cables connected to the display (could this also led to the diagnostic leds not working?)
 
If I move really close to the psu, I can hear two clicking sounds alternating..one is louder than the other.
 
12. What more could I try to diagnose the problem? (Maybe I missed something?)
12. What more could I try to diagnose the problem? (Maybe I missed something?)
 
23. Could the coin cell or any other part be the problem?
23. Could the coin cell or any other part be the problem?
 
34. Also, I have a question about the psu apple part number. It's the ADP-200DFB. What's the difference to the 661-5299 or 614-0444 which I can buy here on ifixit?
34. Also, I have a question about the psu apple part number. It's the ADP-200DFB. What's the difference to the 661-5299 or 614-0444 which I can buy here on ifixit?
 
45. And finally, why are those parts so expensive? I mean >130$ for a psu? It's just a crappy psu, shouldn't be any special, should it?
45. And finally, why are those parts so expensive? I mean >130$ for a psu? It's just a crappy psu, shouldn't be any special, should it?
 
Thank you very, very much :)
Thank you very, very much :)
 
Kind regards

Device:

iMac Intel 21.5" EMC 2428

Status:

open

Original post by: Jacob ,

Title:

iMac won't power on, no LEDs blinking

Text:

Hi there,

our 2428 iMac had some strange behaviour until it got worse:

Some day, after disconnecting the power cord (after shutting down), the mac didn't turn on again. No fans spinning, nothing.

Leaving it disconnected for ~24h would helped and it started.

Any apple authorized service worker couldn't help / identify the problem.

Also a buzzing sound appeared (don't know if this one is maybe related to the power-on-problem).

Now, after disconnecting the device again after months of using, it won't power on - even after waiting those 24h...I opened the imac to look at the diagnostic leds, connected the power cord and tried to power on several times...none of the four leds were blinking. I also tried another power cord and the SMC reset. It did not help ):

If I move really close to the psu, I can hear two clicking sounds alternating..one is louder than the other.

1. What more could I try to diagnose the problem? (Maybe I missed something?)

2. Could the coin cell or any other part be the problem?

3. Also, I have a question about the psu apple part number. It's the ADP-200DFB. What's the difference to the  661-5299 or 614-0444 which I can buy here on ifixit?

4. And finally, why are those parts so expensive? I mean >130$ for a psu? It's just a crappy psu, shouldn't be any special, should it?

Thank you very much :)

Kind regards

Device:

iMac Intel 21.5" EMC 2428

Status:

open