Skip to main content

Fix Your Stuff

Right to Repair

Store

Help

Current version by: Shaun Steele ,

Text:

If this problem is occurring with battery power, try changing the batteries and turning the power back on using this [https://www.ifixit.com/Guide/Altec+Lansing+inMotion+iM9+Battery+Replacement/37910 | guideguide|37910|guide].
If this problem is occurring with battery power, try changing the batteries and turning the power back on using this [https://www.ifixit.com/Guide/Altec+Lansing+inMotion+iM9+Battery+Replacement/37910 | guideguide|37910|guide].
 
If it is with AC power, make sure the cable is properly plugged into the wall and the speaker properlyspeaker.
If it is with AC power, make sure the cable is properly plugged into the wall and the speaker properlyspeaker.
 
If neither of these work, the power connector on the back of the speaker may be damaged and needs to be replaced.
 
Check the troubleshooting page if there is still trouble:
 
[[Altec Lansing inMotion iM9 Troubleshooting]]

Status:

open

Edit by: Shaun Steele ,

Text:

If this problem is occurring with battery power, try changing the batteries and turning the power back onon using this [https://www.ifixit.com/Guide/Altec+Lansing+inMotion+iM9+Battery+Replacement/37910 | guide].
If this problem is occurring with battery power, try changing the batteries and turning the power back onon using this [https://www.ifixit.com/Guide/Altec+Lansing+inMotion+iM9+Battery+Replacement/37910 | guide].
 
If it is with AC power, make sure the cable is plugged into the wall and the speaker properly.
 
If neither of these work, the power connector on the back of the speaker may be damaged and needs to be replaced.
 
Check the troubleshooting page if there is still trouble:
https://www.ifixit.com/Wiki/Altec_Lansing_inMotion_iM9_Troubleshooting
[[Altec Lansing inMotion iM9 Troubleshooting]]
https://www.ifixit.com/Wiki/Altec_Lansing_inMotion_iM9_Troubleshooting
[[Altec Lansing inMotion iM9 Troubleshooting]]

Status:

open

Edit by: Shaun Steele ,

Text:

If this problem is occurring with battery power, try changing the batteries and turning the power back on.
 
If it is with AC power, make sure the cable is plugged into the wall and the speaker properly.
 
If neither of these work, the power connector on the back of the speaker may be damaged and needs to be replaced.
 
Check the troubleshooting page if there is still trouble:
https://www.ifixit.com/Wiki/Altec_Lansing_inMotion_iM9_Troubleshooting

Status:

open

Original post by: Shaun Steele ,

Text:

If this problem is occurring with battery power, try changing the batteries and turning the power back on.

If it is with AC power, make sure the cable is plugged into the wall and the speaker properly.

If neither of these work, the power connector on the back of the speaker may be damaged and needs to be replaced.

Status:

open