Skip to main content
Help

Current version by: Dayna ,

Title:

Replaced 3DSXL screen, but it's not responding. Why?

Text:

I swapped out the defective touch screen from my Pikachu 3DS XL for another touch screen from a Blue X & Y 3DS XL (the screen on the X & Y one was working fine). I followed the step by step directions on this site exactly and was careful not to damage or bend any of the ribbons, connecting ports or other interior bits I was interacting with on both systems. When I turned the Pikachu 3DS XL on, nothing was responding. The power light was on and I could see a slight flicker of light from both screens, but that was it. There was no sound, and the system didn't appear to start up. The wifi switch does not light up when pushed, and I can still turn the system off by holding the power button. I tried taking it apart again to double check that all of the ribbons were connected properly to their ports, and locked in place. I triple checked everything the second time to be sure they were all in. But I got the same response when I tried turning it on again.

Is there a particular connection for all this that I should be paying more attention to? Did I damage something that is preventing it from working? Any more troubleshooting I can try?

Device:

Nintendo 3DS XL

Status:

open

Accepted Answer:

208458

Original post by: Dayna ,

Title:

Replaced 3DSXL screen, but it's not responding. Why?

Text:

I swapped out the defective touch screen from my Pikachu 3DS XL for another touch screen from a Blue X & Y 3DS XL (the screen on the X & Y one was working fine). I followed the step by step directions on this site exactly and was careful not to damage or bend any of the ribbons, connecting ports or other interior bits I was interacting with on both systems. When I turned the Pikachu 3DS XL on, nothing was responding. The power light was on and I could see a slight flicker of light from both screens, but that was it. There was no sound, and the system didn't appear to start up. The wifi switch does not light up when pushed, and I can still turn the system off by holding the power button. I tried taking it apart again to double check that all of the ribbons were connected properly to their ports, and locked in place. I triple checked everything the second time to be sure they were all in. But I got the same response when I tried turning it on again.

Is there a particular connection for all this that I should be paying more attention to? Did I damage something that is preventing it from working? Any more troubleshooting I can try?

Device:

Nintendo 3DS XL

Status:

open