Skip to main content

Fix Your Stuff

Right to Repair

Store

Help

Current version by: iRobot (vote details) ,

Text:

A grey white washed screen? I experienced this problem when replacing my screen and found out why this is happening..

When connecting the ribbon from the screen onto the bottom board that has the charging port ([http://www.futuresupplier.com/media/catalog/product/F/S/FSLG14022419125-3.jpg|this]), the ribbon has a small amount of circuitry and components ([http://i01.i.aliimg.com/wsphoto/v2/708074247_4/Replacement-Part-for-LG-G2-VS980-LCD-Screen-and-Digitizer-Assembly-Black.jpg|the second piece from the left]). The original would have adhesive to stick to the (charging port) board, and the absence of that means that the circuitry will touch against the metal part of the (white) antenna cable that is connected there too.

After trying (and failing( to adhere the ribbon firmly to the board underneath, I simply cut a small piece of electrical tape and placed it in between the antenna and ribbon and solved the problem.

Hope this helps!

Status:

deletedopen
deletedopen

Edit by: iRobot (vote details) ,

Text:

A grey white washed screen? I experienced this problem when replacing my screen and found out why this is happening..

When connecting the ribbon from the screen onto the bottom board that has the charging port ([http://www.futuresupplier.com/media/catalog/product/F/S/FSLG14022419125-3.jpg|this]), the ribbon has a small amount of circuitry and components ([http://i01.i.aliimg.com/wsphoto/v2/708074247_4/Replacement-Part-for-LG-G2-VS980-LCD-Screen-and-Digitizer-Assembly-Black.jpg|the second piece from the left]). The original would have adhesive to stick to the (charging port) board, and the absence of that means that the circuitry will touch against the metal part of the (white) antenna cable that is connected there too.

After trying (and failing( to adhere the ribbon firmly to the board underneath, I simply cut a small piece of electrical tape and placed it in between the antenna and ribbon and solved the problem.

Hope this helps!

Status:

opendeleted
opendeleted

Edit by: Kevin Compagno ,

Text:

A grey white washed screen? I experienced this problem when replacing my screen and found out why this is happening..
 
When connecting the ribbon from the screen onto the bottom board that has the charging port ([http://www.futuresupplier.com/media/catalog/product/F/S/FSLG14022419125-3.jpg|this]), the ribbon has a small amount of circuitry and componentscomponents ([http://i01.i.aliimg.com/wsphoto/v2/708074247_4/Replacement-Part-for-LG-G2-VS980-LCD-Screen-and-Digitizer-Assembly-Black.jpg|the second piece from the left]). The original would have adhesive to stick to the (charging port) board, and the absence of that means that the circuitry will touch against the metal part of the (white) antenna cable that is connected there too.
When connecting the ribbon from the screen onto the bottom board that has the charging port ([http://www.futuresupplier.com/media/catalog/product/F/S/FSLG14022419125-3.jpg|this]), the ribbon has a small amount of circuitry and componentscomponents ([http://i01.i.aliimg.com/wsphoto/v2/708074247_4/Replacement-Part-for-LG-G2-VS980-LCD-Screen-and-Digitizer-Assembly-Black.jpg|the second piece from the left]). The original would have adhesive to stick to the (charging port) board, and the absence of that means that the circuitry will touch against the metal part of the (white) antenna cable that is connected there too.
 
After trying (and failing( to adhere the ribbon firmly to the board underneath, I simply cut a small piece of electrical tape and placed it in between the antenna and ribbon and solved the problem.
 
Hope this helps!

Status:

open

Original post by: Kevin Compagno ,

Text:

A grey white washed screen? I experienced this problem when replacing my screen and found out why this is happening..

When connecting the ribbon from the screen onto the bottom board that has the charging port ([http://www.futuresupplier.com/media/catalog/product/F/S/FSLG14022419125-3.jpg|this]), the ribbon has a small amount of circuitry and components. The original would have adhesive to stick to the (charging port) board, and the absence of that means that the circuitry will touch against the metal part of the (white) antenna cable that is connected there too.

After trying (and failing( to adhere the ribbon firmly to the board underneath, I simply cut a small piece of electrical tape and placed it in between the antenna and ribbon and solved the problem.

Hope this helps!

Status:

open