Skip to main content
Help

Original post by: Justin ,

Text:

I had been struggling with this issue for the better part of 3 weeks until I finally found a solution.  I haven't seen it mentioned here -

-In my case, my problem had started with the NAND error after putting a new screen on.

-Put the old cracked screen on and it seemed to work.

-After unplugging and plugging the new screen in a bunch of times AND doing the restore, it seemed to boot correctly.

-Once in a while the phone would shut down and boot back to the NAND error again, and after about 20 resets it would somehow 'luckily' boot correctly.

-After about 2 more weeks, it stopped ever booting correctly and booted only to the NAND screen ever no matter what I did.

-I tried to do the DFU Mode / Restore thing again since that had worked once before.

-Still no dice.

-I READ ON THE GSM FORUM ABOUT THE COMPASS IC which is SUPER CLOSE to where the Front Camera Flex Cable plugs in.  A user said just to remove it.  I have no soldering experience so I simply pried it off with a metal clip.

-Voila, finally got passed the -4013 error in the Restore screen, and now I have a functional phone again, probably without a compass feature, but I have been trying to make this phone last as I am still under contract for a couple more months.

It makes sense to me that possibly people are damaging this tiny sensitive chip when swapping screens, and that is causing the hardware check to fail upon boot.  The only thing that has changed in my phone's functionality now is that the compass app doesn't work.  Maps, etc. still function fine.

Status:

open