Skip to main content
Help

Original post by: machracing360 ,

Text:

Hi

I read all of your replies above and decided that my issue was similar and can now happily say that my N7 works,  so read on...

I have a N7 which is out of warranty. Yesterday it was working fine, put it in my bag when I went out shopping, and when I arrived home, having not used it, the tablet would not boot up!!! Arrrrrhhh! I have a well padded,  leather bag and so should have had enough protection not to damage the N7, and the tablet was also in a fully protective case.

The screen was blank/ black and would not respond to any button pressing ......... tried the on/off with the down volume, etc, etc, and nothing. I plugged the pad into the Nexus charging cable and the screen changed to a very low light with large white vertical dashes flashing up and down the screen. I tried at this point to reboot the tablet, but nothing happened.

So I decided to bravely attempt to open up the N7 ( which was very easy ), and see if the connections were loose as many of you had described in the answers above. Upon closer inspection, the connector from the battery to the socket on the motherboard had very slightly worked itself out. Whilst it had not completely come out, it was less than a millimetre out of the socket.

I was able to push the connector back in with my finger nail. Once the back was put on, the tablet booted up like normal.

I hope this helps anyone with the same issue. Try the link below which shows how to take the back of the tablet off and where the connector is ( step 6 on the guide).

[guide|9895]

Nick Hancock

Status:

open