Help

Current version by oldturkey03 (vote details),

Title:

Is this a display data cable problem?

Text:

Hi there! I have a problem with my MBP 2,2 GHz Quad-core with the AMD Radeon HD 6750M graphic card (early 2011). It is upgraded to OS X Lion (v. 10.7.5) The problem is that the computer display stays black after startup. When i connect an external display the computer works like normal even though the screen on the computer is still black. It happened a couple of times before, but a restart or two would make the problem go away. This time though the problem persists and I haven't been able to get the screen back on. I have tried to reset SMC, reset NVRAM/PRAM, booting in safe mode and reinstalling OS X, but none of it worked. I have tried running the extended mac hardware test, but this found nothing to be wrong. I can't see an image when i shine a flashlight into the screen. Under the hardware tab in the "System report" I can't seem to find the display and when i try the "Detect display" under systempreferences only the external display monitor is detected. [image|283604|align=left] [image|283605|align=left] [image|283606|align=left] Also normally when I push down the display, the computer goes into sleep mode. Now nothing happens when i close down the lid and the computer just keeps on going like normal. I haven't been able to find someone with the exact same symptoms on the internet. As of what I can find on the internet of people having somewhat similar symptoms I am thinking it might be a display data cable problem, but since I have never opened up a laptop I would like to be sure before I open up my computer, if it is maybe still just a software problem. Any help on what could be wrong and how to fix it is much appreciated! :)

Device:

MacBook Pro 15" Unibody Early 2011

Tags:

display black, display data cable, Troubleshoot black display, external display only

Status:

open

Accepted Answer:

145838

Edit by machead3,

Title:

Is this a display data cable problem?

Text:

Hi there! I have a problem with my MBP 2,2 GHz Quad-core with the AMD Radeon HD 6750M graphic card (early 2011). It is upgraded to OS X Lion (v. 10.7.5) The problem is that the computer display stays black after startup. When i connect an external display the computer works like normal even though the screen on the computer is still black. It happened a couple of times before, but a restart or two would make the problem go away. This time though the problem persists and I haven't been able to get the screen back on. I have tried to reset SMC, reset NVRAM/PRAM, booting in safe mode and reinstalling OS X, but none of it worked. I have tried running the extended mac hardware test, but this found nothing to be wrong. I can't see an image when i shine a flashlight into the screen. Under the hardware tab in the "System report" I can't seem to find the display and when i try the "Detect display" under systempreferences only the external display monitor is detected. [image|283604|align=left] [image|283605|align=left] [image|283606|align=left] Also normally when I push down the display, the computer goes into sleep mode. Now nothing happens when i close down the lid and the computer just keeps on going like normal. I haven't been able to find someone with the exact same symptoms on the internet. As of what I can find on the internet of people having somewhat similar symptoms I am thinking it might be a display data cable problem, but since I have never opened up a laptop I would like to be sure before I open up my computer, if it is maybe still just a software problem. Any help on what could be wrong and how to fix it is much appreciated! :)

Device:

MacBook Pro 15" Unibody Early 2011

Tags:

display black, display data cable, Troubleshoot black display, external display only
display black, display data cable, Troubleshoot black display, external display only

Status:

open

Original post by Bredholt,

Title:

Is this a display data cable problem?

Text:

Hi there! I have a problem with my MBP 2,2 GHz Quad-core with the AMD Radeon HD 6750M graphic card (early 2011). It is upgraded to OS X Lion (v. 10.7.5) The problem is that the computer display stays black after startup. When i connect an external display the computer works like normal even though the screen on the computer is still black. It happened a couple of times before, but a restart or two would make the problem go away. This time though the problem persists and I haven't been able to get the screen back on. I have tried to reset SMC, reset NVRAM/PRAM, booting in safe mode and reinstalling OS X, but none of it worked. I have tried running the extended mac hardware test, but this found nothing to be wrong. I can't see an image when i shine a flashlight into the screen. Under the hardware tab in the "System report" I can't seem to find the display and when i try the "Detect display" under systempreferences only the external display monitor is detected. [image|283604|align=left] [image|283605|align=left] [image|283606|align=left] Also normally when I push down the display, the computer goes into sleep mode. Now nothing happens when i close down the lid and the computer just keeps on going like normal. I haven't been able to find someone with the exact same symptoms on the internet. As of what I can find on the internet of people having somewhat similar symptoms I am thinking it might be a display data cable problem, but since I have never opened up a laptop I would like to be sure before I open up my computer, if it is maybe still just a software problem. Any help on what could be wrong and how to fix it is much appreciated! :)

Device:

MacBook Pro 15" Unibody Early 2011

Tags:

display black, display data cable, external display only

Status:

open