Skip to main content

Fix Your Stuff

Right to Repair

Store

Help

Current version by: mister790 ,

Text:

That's a pretty old browser on a pretty old system -- it could be that modern webpages are overwhelming it. Have you been able to pinpoint which sites or processes seem to overwhelm it?
 
You might want to try an alternate browser -- like iCab 3.0.5 for PPC, which should be compatible with your system: http://icab.de/dl.php . Still might feel slow and still might crash, but it's a free download and probably worth a shot.
 
UPDATE: And here's a link to the last version of Firefox that worked with OS 10.1: http://mac.oldapps.com/firefox.php?old_firefox=7

Status:

open

Edit by: mister790 ,

Text:

That's a pretty old browser on a pretty old system -- it could be that modern webpages are overwhelming it. Have you been able to pinpoint which sites or processes seem to overwhelm it?
That's a pretty old browser on a pretty old system -- it could be that modern webpages are overwhelming it. Have you been able to pinpoint which sites or processes seem to overwhelm it?
 
You might want to try an alternate browser -- like iCab 3.0.5 for PPC, which should be compatible with your system: http://icab.de/dl.php . Still might feel slow and still might crash, but it's a free download and probably worth a shot.

Status:

open

Original post by: mister790 ,

Text:

That's a pretty old browser on a pretty old system -- it could be that modern webpages are overwhelming it.

You might want to try an alternate browser -- like iCab 3.0.5 for PPC, which should be compatible with your system:  http://icab.de/dl.php .  Still might feel slow and still might crash, but it's a free download and probably worth a shot.

Status:

open