Help

Current version by Colin,

Title:

Microphone not working after LOCA UV glue repair

Text:

I cracked the screen on my S3 a few weeks back, fortunately just the front glass. I replaced the broken glass with a new one from ebay, used 2mm double sided tape to hold it in place, it worked great. Until the other day when I tried bonding the glass to the LCD using LOCA UV glue. I got the glass bonded to the LCD nicely, that part went well, but for some reason the microphone stopped working. At first the microphone did work a tiny bit, it was able to pickup loud knocking noises. I tried using a needle to clean out the microphone hole, on the bottom of the phone, that didn't help. Next I opened the s3, removed the main board, and checked both the microphones. Could not see any obvious problems, except that the microphones were covered in LOCA glue, still in liquid state. I cleaned the microphones, and very gently used the needle to clear the loca from the tiny hole on the microphones. After putting the phone back together, the microphones now don't pickup any noise at all. The rest of the phone is all working fine, just microphones not working. should I try replace the microphones? is it a difficult job to replace the microphones? Any help appreciated.

Device:

Samsung Galaxy S III

Tags:

glass, glue, lcd, loca

Status:

open

Accepted Answer:

139995

Original post by Colin,

Title:

Microphone not working after LOCA UV glue repair

Text:

I cracked the screen on my S3 a few weeks back, fortunately just the front glass. I replaced the broken glass with a new one from ebay, used 2mm double sided tape to hold it in place, it worked great. Until the other day when I tried bonding the glass to the LCD using LOCA UV glue. I got the glass bonded to the LCD nicely, that part went well, but for some reason the microphone stopped working. At first the microphone did work a tiny bit, it was able to pickup loud knocking noises. I tried using a needle to clean out the microphone hole, on the bottom of the phone, that didn't help. Next I opened the s3, removed the main board, and checked both the microphones. Could not see any obvious problems, except that the microphones were covered in LOCA glue, still in liquid state. I cleaned the microphones, and very gently used the needle to clear the loca from the tiny hole on the microphones. After putting the phone back together, the microphones now don't pickup any noise at all. The rest of the phone is all working fine, just microphones not working. should I try replace the microphones? is it a difficult job to replace the microphones? Any help appreciated.

Device:

Samsung Galaxy S III

Tags:

glass, glue, lcd, loca

Status:

open