Skip to main content
Help

Current version by: oldturkey03 (vote details) ,

Text:

ana, sounds like you have a stuck lens. Look at it straight on and see if it looks center in the housing. Sometimes dirt, sand and grime can prevent it from opening. In case like that I usually try to use a vacuum cleaner at the front of the lens and try to assist it with that suction, while turning the camera on. Take a look [http://camerarepair.blogspot.com/2007/12/fixing-lens-error-on-digital-camera.html|on here] for some more information. Hope this helps, good luck.

Status:

-deleted
+open

Edit by: mayer (vote details) ,

Text:

ana, sounds like you have a stuck lens. Look at it straight on and see if it looks center in the housing. Sometimes dirt, sand and grime can prevent it from opening. In case like that I usually try to use a vacuum cleaner at the front of the lens and try to assist it with that suction, while turning the camera on. Take a look [http://camerarepair.blogspot.com/2007/12/fixing-lens-error-on-digital-camera.html|on here] for some more information. Hope this helps, good luck.

Status:

-open
+deleted

Original post by: oldturkey03 ,

Text:

ana, sounds like you have a stuck lens. Look at it straight on and see if it looks center in the housing. Sometimes dirt, sand and grime can prevent it from opening. In case like that I usually try to use a vacuum cleaner at the front of the lens and try to assist it with that suction, while turning the camera on. Take a look [http://camerarepair.blogspot.com/2007/12/fixing-lens-error-on-digital-camera.html|on here] for some more information. Hope this helps, good luck.

Status:

open