Skip to main content
Help

Current version by: oldturkey03 (vote details) ,

Title:

Mbp doesnt boot anymore

Text:

I had an issue ith my macbook pro. It was showing just colours, no image. I thought it was a loose connection, so I opened the thing up, unplugged the battery, checked the connection and closed it back up.

Now the thing is completely dead... Wel... Not completely. The MagSafe led burns when I connect it, and the battery charges, if I may trust the battery indicators. Apart from that, it does nothing. I also noticed that, although the machine does not boot, the battery runs out in a few hours after having charged completely.

I tried the SMC reset ( it makes the led change from orange to green, and back again), the main board reset, short-circuiting the startup pins,... Nothing.

If you guys could help me out, it'd be great.

Thanks,

Sam

Btw: it's a 13" MBP model n° A1278

Device:

MacBook Pro 13"

Status:

-open
+closed

Original post by: Sam Bouckaert ,

Title:

Mbp doesnt boot anymore

Text:

I had an issue ith my macbook pro. It was showing just colours, no image. I thought it was a loose connection, so I opened the thing up, unplugged the battery, checked the connection and closed it back up.

Now the thing is completely dead... Wel... Not completely. The MagSafe led burns when I connect it, and the battery charges, if I may trust the battery indicators. Apart from that, it does nothing. I also noticed that, although the machine does not boot, the battery runs out in a few hours after having charged completely.

I tried the SMC reset ( it makes the led change from orange to green, and back again), the main board reset, short-circuiting the startup pins,... Nothing.

If you guys could help me out, it'd be great.

Thanks,

Sam

Btw: it's a 13" MBP model n° A1278

Device:

MacBook Pro 13"

Status:

open