1

Score

Avatar
David
13

Asked

LED 1 goes off when I press the power button

History

Hi there,

I have an IMAC 20 Isight and am having starting up problems.

I have opened up my mac and uncovered the 4 LED which are hidden behind the right speaker.

When I connect the power cable to the mac. The 1st LED lights up. But when I press the power button, the 1st LED goes out and none of the others light up. I have reset the SMU and that didnt help.

Does anyone have any idea what it could be.

Update

Hi Mayer, it's not the PSU. I got a replacement PSU and still have the same problem. LED 1 lights up when I connect the power cable. But once I press the power button the LED1 goes out and none of the others lit up. Any suggestions?

Edited by: David ( ) , mayer ( )

Hi Mayer, it's not the PSU. I got a replacement PSU and still have the same problem. LED 1 lights up when I connect the power cable. But once I press the power button the LED1 goes out and none of the others lit up. Any suggests?

David,

I had exactly the same problem. I took a working standard ATX PSU from a Windows PC, remapped the cables so they matched the iMac's pinout, and it started working. After that, I reinstalled the iMac's PSU and it also worked!!! I really don't know why, though...

Mauricio Blanco,

Post Answer

4

Score

Avatar
mayer
198.9k

Answered

PermalinkHistory

I've corrected the machine picture and corresponding repair guides to the G5 iMac you have. Apple iMac G5/2.1 20-Inch (iSight) Specs

Identifiers: iSight - MA064LL/A - PowerMac12,1 - A1145 - 2082

Here's the power supply you need: http://www.dvwarehouse.com/Power-Supply-...

Add Your Answer

View Statistics:

Today: 0

This Week: 0

This Month: 1

All Time: 970