4

Score

Avatar
jkyriazidis
49

Asked

iMac presents symptomatology of HDD failure & Graphics Card failure!

History

Dear Mac Users,

i am desperate for true help.

My iMac one day on boot presented a white screen with a folder with a question mark on it. After extensive test i four that probably is a HDD failure. I replaced the default Toshiba HDD with Seagate ST31000524AS 1TB, and i installed Lion on it. Everything was working great!...for 1 week. Let's cut into chase. Pathologic symptomatology started the day before yesterday (1st day), continued with quite a bit different form yesterday (2nd day) until today (3rd day).

1st day:

In the morning iMac used to freeze when i was working with him. Also there where times (few) with screen distortions and times (about 10, starting from yesterday) when the beach loading ball was appearing.

On the afternoon i found my iMacs screen freezed. Nothing was happening. I tried to restart, but with no luck. Startup hangs on the Apple logo with the loading circle there. I also did the following:

1. I did reset the PRAM. iMac booted 10 minutes and freezed immediately, i could operate it at all.

2. Three more times i tried to reboot it stuck on the Apple logo.

3. I pulled out the RAMS and chime does sound (check for logic board failure i found on Google, but i do believe it is a graphics or logic board issue).

4. I did boot from Verbose mode and there is an error message coming up write from the start when system is loading drivers saying "failed to load AppleUSBblablabla.kext (i don't quite remember more from the name cause iMac rebooted and i didn't memorize it).

5. Perhaps iMac is hotter than before.

6. I tried to see iMac from Macbook Pro via firewire but with no luck (firewire logo was flashing on the screen of iMac though).

2nd day: Morning

Today i went to an apple authorized technician.

I explained to him everything i tried. First thing he managed to do is to start the computer. White screen again..

Afterwards, he tried to start something like hardware test (edit: finally i learned that was the cooling diagnostics) but from the local network. It succeeded. 2 errors found: one red warning for the graphics card and one orange/ yellow for the HDD.

Last thing he did, he boot from an external hard drive. Black screen, appeared. Technician decided to do a hard reset, an when he pressed the power button, boom! The desktop appeared. Yeah, it is weird!

That moment i left the technician to do the rest. He telephoned me after 45 minutes. He proposed to replace the graphics card and afterwards the HDD. I explained to him that i dont think this is the best way to follow, cause ten days ago, as you read, i replaced the HDD already. So something else might be the problem that on second time triggers problems to the graphics card and to the HDD. He could not answer what is the cause of the these problems...

2nd day afternoon:

i managed to find apple service diagnostics and after many many unreasonable errors of disk utility i managed to put it on a usb.

I tried 2 times to run the EFI service diagnostics and i noticed that the iMac seemed to froze after 40 minutes, although the time was running. Then exactly i remembered the words of the technician. "probably it is the graphics card that cause the screen to froze, but the timer is running".

From my nature i am a perfectionist, and many times i believe that people dont give all of their efforts on resolving a problem of someone's else. So i decided to run the EFI one more time and just leave it...i went to play a bingo. I won 260 Euros. "the money for the replacement of the graphics card!..." i thought...

When i returned home after 2 hours the EFI test was almost complete!!! 2 errors found. Here are the pics:

http://cl.ly/3z2j0Z443R0j1B2O0i3s

and

http://cl.ly/0U0l3s0J0l1E2V3H0u3W

So the first one says:

a. Fan HDD test 2-Long Motor Test

System turns on motor and verifies that the motor is on.

ERROR - Motor did not reach target speed in time

TEST FAILED

b. Short random multi-block test test 1 - Full Read Test (DMA Full Read Scan at 1250)

- Reads the entire HD checking for slow - read failures.

ERROR - Reading took longer than the average time

- TEST FAILED -

What draw my attention was the fact that the EFI service diagnostics UI, is different from the one that technician run...then i think i remembered a post on the apple service diagnostics thread, which referred to the fan control something...i got really suspicious. I immediately wrote an email to the technician asking him if what he did is to run the fan control check program....

He replied...yes...

So i think that he just checked the fans of the system? And this fan check showed problems on the graphics card fan(!?)...i was there when this operation took place, but i didnt know what was going on. So if it truly was a test of all iMac's fans, then how he concluded that there is a problem with the graphics card?Hmm....

I want to add that i tried to put my macbook pro on FW mode in order to chose it as startup disc from the iMac. If the OS would load fine then it would be a HDD problem. Unfortunately, the system seemed to hang up, but i have to admit that i could leave it a little bit longer in order to see what will happen at the end. But, i then thought, if everything expect the HDD was fine, then the iMac should start normally...

2nd day: 3 hours later

i put now my macbook pro in fw mode and on the second attempt i managed to boot. login and see the whole system from my iMac. Currently i am writing from my iMac which sees the Macbook Pro via FW. No screen distortions, no nothing...

so, what does this experiment tells to us?

Furthermore i did succeed to boot from a USB running Lion installer. When i went to disc utility and selected the internal HDD of iMac this message appeared:

"This drive has a hardware problem that can't be repaired. Backup as much of the data as possible and replace the disk. See an authorized Apple dealer for more information". Also there was a "SMART status: failing"

http://cl.ly/1R2N121z1l0T0k1W0p0C

Could the HDD cause all the problems? It is a SEAGATE...maybe it is incompatible?

Here is an Apple error report from the first unsuccessful try to boot Lion from Macbook Pro on iMac via FW.

Interval Since Last Panic Report: 23 sec

Panics Since Last Report: 1

Anonymous UUID: 390B7874-EDE6-4E2A-B20E-EC75285BD7DC

Wed Aug 3 23:45:43 2011

panic(cpu 0 caller 0xffffff80002c268d): Kernel trap at 0xffffff7f80c746a6, type 14=page fault, registers:

CR0: 0x0000000080010033, CR2: 0x000000000000000c, CR3: 0x0000000000100000, CR4: 0x0000000000000660

RAX: 0x0000000000000000, RBX: 0x00000000000015cc, RCX: 0x0000000000000000, RDX: 0x0000000000000000

RSP: 0xffffff808010bdf0, RBP: 0xffffff808010bea0, RSI: 0x00000000ffffffff, RDI: 0x0000000000000000

R8: 0x0000000000000008, R9: 0x00000000fffffff8, R10: 0x0000000080808081, R11: 0x0000000000000000

R12: 0x0000000000000000, R13: 0x0000000000000000, R14: 0x000000000000000c, R15: 0xffffff80741b02cc

RFL: 0x0000000000010293, RIP: 0xffffff7f80c746a6, CS: 0x0000000000000008, SS: 0x0000000000000010

CR2: 0x000000000000000c, Error code: 0x0000000000000000, Faulting CPU: 0x0

Backtrace (CPU 0), Frame : Return Address

0xffffff808010bab0 : 0xffffff8000220702

0xffffff808010bb30 : 0xffffff80002c268d

0xffffff808010bcd0 : 0xffffff80002d7a3d

0xffffff808010bcf0 : 0xffffff7f80c746a6

0xffffff808010bea0 : 0xffffff7f80c765b7

0xffffff808010bef0 : 0xffffff8000639536

0xffffff808010bf30 : 0xffffff80006382b0

0xffffff808010bf70 : 0xffffff8000638154

0xffffff808010bfb0 : 0xffffff8000820057

Kernel Extensions in backtrace:

com.apple.iokit.IOGraphicsFamily(2.3)[897EB322-FD55-36D7-A68E-9E9C34A74A84]@0xffffff7f80c63000->0xffffff7f80c9afff

dependency: com.apple.iokit.IOPCIFamily(2.6.5)[95ABB490-3AB5-3D5E-9C21-67089A9AE6A1]@0xffffff7f8083e000

BSD process name corresponding to current thread: kernel_task

Mac OS version:

11A511

Kernel version:

Darwin Kernel Version 11.0.0: Sat Jun 18 12:56:35 PDT 2011; root:xnu-1699.22.73~1/RELEASE_X86_64

Kernel UUID: 24CC17EB-30B0-3F6C-907F-1A9B2057AF78

System model name: iMac8,1 (Mac-F227BEC8)

System uptime in nanoseconds: 367855081214

last loaded kext at 137407698443: com.apple.driver.AppleHIDKeyboard 152.3 (addr 0xffffff7f81d16000, size 12288)

loaded kexts:

at.obdev.nke.LittleSnitch 2.4.0

com.apple.driver.AppleHWSensor 1.9.4d0

com.apple.iokit.IOAHCIBlockStorage 2.0.0

com.apple.filesystems.autofs 3.0

com.apple.driver.AppleUpstreamUserClient 3.5.9

com.apple.driver.AppleMCCSControl 1.0.24

com.apple.GeForce 7.0.2

com.apple.driver.AppleTyMCEDriver 1.0.2d2

com.apple.driver.AirPortBrcm43224 500.36.11

com.apple.iokit.AppleYukon2 3.2.2b1

com.apple.driver.AppleHDA 2.1.1f11

com.apple.driver.ACPI_SMC_PlatformPlugin 4.7.0b2

com.apple.driver.AudioAUUC 1.59

com.apple.driver.AppleLPC 1.5.1

com.apple.driver.AppleMuxControl 3.0.8

com.apple.driver.AppleBacklight 170.1.9

com.apple.iokit.IOUserEthernet 1.0.0d1

com.apple.Dont_Steal_Mac_OS_X 7.0.0

com.apple.driver.AudioIPCDriver 1.2.0

com.apple.driver.AppleIRController 309

com.apple.driver.AppleFireWireStorage 3.0.0

com.apple.driver.initioFWBridge 3.0.0

com.apple.driver.IOFireWireSerialBusProtocolSansPhysicalUnit 3.0.0

com.apple.driver.LSI_FW_500 3.0.0

com.apple.driver.Oxford_Semi 3.0.0

com.apple.driver.StorageLynx 3.0.0

com.apple.driver.iPodDriver 1.6.0

com.apple.iokit.SCSITaskUserClient 3.0.0

com.apple.AppleFSCompression.AppleFSCompressionTypeDataless 1.0.0d1

com.apple.AppleFSCompression.AppleFSCompressionTypeZlib 1.0.0d1

com.apple.BootCache 32

com.apple.driver.AppleUSBHub 4.4.0

com.apple.driver.AppleAHCIPort 2.1.8

com.apple.driver.AppleEFINVRAM 1.5.0

com.apple.driver.AppleIntelPIIXATA 2.5.1

com.apple.driver.AppleFWOHCI 4.8.6

com.apple.driver.AppleUSBEHCI 4.4.0

com.apple.driver.AppleUSBUHCI 4.4.0

com.apple.driver.AppleRTC 1.4

com.apple.driver.AppleHPET 1.6

com.apple.driver.AppleACPIButtons 1.4

com.apple.driver.AppleSMBIOS 1.7

com.apple.driver.AppleACPIEC 1.4

com.apple.driver.AppleAPIC 1.5

com.apple.driver.AppleIntelCPUPowerManagementClient 166.0.0

com.apple.nke.applicationfirewall 3.0.30

com.apple.security.quarantine 1

com.apple.driver.AppleIntelCPUPowerManagement 166.0.0

com.apple.driver.AppleHIDKeyboard 152.3

com.apple.driver.IOBluetoothHIDDriver 2.5f17

com.apple.kext.triggers 1.0

com.apple.nvidia.nv50hal 7.0.2

com.apple.NVDAResman 7.0.2

com.apple.iokit.IO80211Family 400.40

com.apple.driver.AppleHDAHardwareConfigDriver 2.1.1f11

com.apple.driver.DspFuncLib 2.1.1f11

com.apple.driver.AppleAVBAudio 1.0.0d11

com.apple.driver.IOPlatformPluginFamily 4.7.0b2

com.apple.driver.AppleSMBusPCI 1.0.10d0

com.apple.driver.AppleGraphicsControl 3.0.8

com.apple.driver.AppleBacklightExpert 1.0.3

com.apple.iokit.IONDRVSupport 2.3

com.apple.driver.AppleHDAController 2.1.1f11

com.apple.iokit.IOHDAFamily 2.1.1f11

com.apple.iokit.IOFireWireIP 2.2.3

com.apple.iokit.IOSurface 80.0

com.apple.iokit.IOGraphicsFamily 2.3

com.apple.iokit.IOBluetoothSerialManager 2.5f17

com.apple.iokit.IOSerialFamily 10.0.5

com.apple.iokit.IOAVBFamily 1.0.0d22

com.apple.iokit.IOEthernetAVBController 1.0.0d5

com.apple.driver.AppleSMC 3.1.1d2

com.apple.iokit.IOAudioFamily 1.8.3fc11

com.apple.kext.OSvKernDSPLib 1.3

com.apple.driver.XsanFilter 403

com.apple.driver.AppleFileSystemDriver 13

com.apple.driver.BroadcomUSBBluetoothHCIController 2.5f17

com.apple.driver.AppleUSBBluetoothHCIController 2.5f17

com.apple.iokit.IOBluetoothFamily 2.5f17

com.apple.iokit.IOUSBHIDDriver 4.4.0

com.apple.driver.AppleUSBMergeNub 4.4.0

com.apple.iokit.IOSCSIBlockCommandsDevice 3.0.0

com.apple.iokit.IOUSBMassStorageClass 3.0.0

com.apple.driver.AppleUSBComposite 3.9.0

com.apple.iokit.IOFireWireSerialBusProtocolTransport 2.1.0

com.apple.iokit.IOSCSIReducedBlockCommandsDevice 3.0.0

com.apple.iokit.IOFireWireSBP2 4.2.0

com.apple.iokit.IOSCSIMultimediaCommandsDevice 3.0.0

com.apple.iokit.IOBDStorageFamily 1.6

com.apple.iokit.IODVDStorageFamily 1.6

com.apple.iokit.IOCDStorageFamily 1.7

com.apple.iokit.IONetworkingFamily 2.0

com.apple.iokit.IOATAPIProtocolTransport 3.0.0

com.apple.iokit.IOSCSIArchitectureModelFamily 3.0.0

com.apple.iokit.IOAHCIFamily 2.0.6

com.apple.iokit.IOUSBUserClient 4.4.0

com.apple.iokit.IOATAFamily 2.5.1

com.apple.iokit.IOFireWireFamily 4.4.3

com.apple.iokit.IOUSBFamily 4.4.0

com.apple.driver.AppleEFIRuntime 1.5.0

com.apple.iokit.IOHIDFamily 1.7.0

com.apple.iokit.IOSMBusFamily 1.1

com.apple.security.sandbox 165

com.apple.kext.AppleMatch 1.0.0d1

com.apple.security.TMSafetyNet 7

com.apple.driver.DiskImages 326

com.apple.iokit.IOStorageFamily 1.7

com.apple.driver.AppleKeyStore 28.18

com.apple.driver.AppleACPIPlatform 1.4

com.apple.iokit.IOPCIFamily 2.6.5

com.apple.iokit.IOACPIFamily 1.4

Model: iMac8,1, BootROM IM81.00C1.B00, 2 processors, Intel Core 2 Duo, 3.06 GHz, 4 GB, SMC 1.30f1

Graphics: NVIDIA GeForce 8800 GS, NVIDIA GeForce 8800 GS, PCIe, 512 MB

Memory Module: BANK 0/DIMM0, 2 GB, DDR2 SDRAM, 800 MHz, 0x2C00000000000000, 0x3136485446323536363448592D3830304531

Memory Module: BANK 1/DIMM1, 2 GB, DDR2 SDRAM, 800 MHz, 0x2C00000000000000, 0x3136485446323536363448592D3830304531

AirPort: spairport_wireless_card_type_airport_extreme (0x14E4, 0x8C), Broadcom BCM43xx 1.0 (5.10.131.36.11)

Bluetooth: Version 2.5.0f17, 2 service, 19 devices, 1 incoming serial ports

Serial ATA Device: ST31000524AS, 1 TB

Parallel ATA Device: OPTIARC DVD RW AD-5630A

USB Device: Built-in iSight, apple_vendor_id, 0x8502, 0xfd400000 / 3

USB Device: Cruzer Edge, 0x0781 (SanDisk Corporation), 0x556b, 0xfd100000 / 2

USB Device: BRCM2046 Hub, 0x0a5c (Broadcom Corp.), 0x4500, 0x1a100000 / 2

USB Device: Bluetooth USB Host Controller, apple_vendor_id, 0x820f, 0x1a110000 / 3

USB Device: Microsoft 5-Button Mouse with IntelliEye(TM), 0x045e (Microsoft Corporation), 0x0039, 0x3a200000 / 2

USB Device: IR Receiver, apple_vendor_id, 0x8242, 0x5d100000 / 2

FireWire Device: fw_target_disk_mode, AAPL, 800mbit_speed

as you see...is there an error with com.apple.iokit.IOGraphicsFamily

3rd day (today):

I run istat menu pro 3. The results are the following:

http://cl.ly/1h3i3S2W3p250J3b191V

They seem normal to me after cross checking them with my cousin's iMac which is the same model as mine. I don't know what the 0s mean, but i rely on you guys!

I finally managed to run Hardware Test from the Leopard DVDs that came with my iMac.

http://cl.ly/222Y2a2e361e0D0p2f3c

Another vote for HDD failure i suppose...

I dont know why, but after the EFI srvice diagnostics, iMac is "stronger" and somehow better.

I run techtool pro 6 which said that the same thing as the disc utility: the HDD needs replacement.

I run then data rescue 3, same message: the HDD is dead.

Did anybody see the pics above? From the EFI service diagnostics emerge 2 errors. I think that one of them comes from HDD2 fan.

So...do,i have a combined problem? Graphics card and HDD.

About the graphics card: when i boot lion that sleeps insid macbook pro from iMac, i cannot see something that rings bells for a graphics card problem...maybe something inside causes the system to overheat?...i dont know...

Currently i am on my iMac using my Macbook Pro as start disc via Firewire. There is not something that make me say: i have a graphics card problem! Maybe the iMac gets too hot and caused the HDD to die and graphics card to slow down?

And moreover i dont know what to fix first...ideas?

Please help!

Edited by: oldturkey03 ( ) , Andrew Bookholt ( ) , jkyriazidis ( )

Post Answer

6

Score

Avatar
mayer
199.3k

Answered

Accepted Answer

PermalinkHistory

I only read the first half of your question because I think I know the possible problem after the first two sentences.

This should be your machine:

Apple iMac "Core 2 Duo" 3.06 24-Inch (Early 2009) Specs

Identifiers: Early 2009 - MB420LL/A - iMac9,1 - A1225 - 2267

Apple was just switching over to the proprietary Apple hard drives at this time that require specific Temperature sensor cables for each brand of hard drive. At least they did with the late 2009 machines. This may not be the problem at all but I think it's worth a shot for $8.50: http://cgi.ebay.com/IMAC-HARD-DRIVE-TEMP...

922-9223 Hitachi

922-9224 Seagate

922-9225 Western Digital

Please give us the last three figures of your serial number (located on the bottom of your stand) so we can be sure of which machine you have. I'm now looking at this machine: Apple iMac "Core 2 Duo" 3.06 24-Inch (Early 2008) Specs Identifiers: Early 2008 - MB398LL/A - iMac8,1 - A1225 - 2211 If your machine is this one, my diagnosis is probably wrong. I'll go back and read it all the way through.

mayer,

+ For saying you'd read it all the way through.

Taylor Arnicar,

Mine is early 2008, this is what is written in "about this mac". Does this change anything on your answer? So is it also a graphics card problem or not? I have almost every result test available for your reference. Edit: the link correspond to sensor for the 27" model. I assume it is the same. What about the graphics card? :S

jkyriazidis,

@Taylor, dont you thing it is a rare complete post? I did whatever i could! Would you expect a noobish post "please my imac stoppedvworking, i dont know what to do?". In my humble opinion i believe that it is a very informative post. Today i ll go to replace my HDD with a WD one. I let you know.

jkyriazidis,

Serial number is: QP83011S0KM The HD i replaced the previous Seagate is a WD10EARX Caviar Green.

jkyriazidis,

Show 3 more comments

0

Score

Avatar
jkyriazidis
49

Answered

PermalinkHistory

From yesterday i run again the system with no problem. Today i decided run again the hardware tests to see if the errors are again there.

The EFI hardware test showed no errors. After the completion of the test, there was a very strong ghost image of the Hardware Test window...

:(

The Apple hardware test (command + D on startup) returned the following error:

4M0T/1/40000003: HDD - 1420.

Same errors found here: https://discussions.apple.com/thread/184..., some of them presenting the same symptomatology as my iMac. One of the guys managed to solved the problem through apple service which replaced the fan, and heat sensor. But which one?

Moreover i boot mac os x on terminal mode (command + S) and i typed:

/sbin/fsck -fy

and the result was: the volume appears to be OK (? confict results eh?)

Edited by: jkyriazidis ( )

Hi jkyriazidis. I´ve read your post and I think I had mostly the same problem. After the last change of my HD (I've replaced two times before) I get the tip to install the app "Temperature Monitor". I've found that there is too hot inside mi iMac (24, emc 2134) with tempreatures in the Graphic Processor Diode about 86 ºC. I supposed the Graphic Processor have some kind of problem, so I'm studying the possibility to repalce it. Are you still trying to repair your iMac? I'll be pleaced to intechange results. Greetings from Mexico. Ernesto Elizalde

Ernesto Elizalde,

Add Your Answer

View Statistics:

Today: 0

This Week: 63

This Month: 186

All Time: 13,910