0

Score

Avatar
Mohamed Ali
1

Asked

Lumia 920 Died. Not charging and not starting up?

History

The phone turned off while my son was playing a game on my Lumia 920. I tried to charge it but it did not charging and even not showing Nokia Logo. It shows nothing, just like died phone. I tried hard and soft reset but nothing works.

I thought it was the charging port because there was small physical defect near by USB charging port (it voided the guaranty). I ordered OEM USB Port Charging Connector Flex Cable. I changed the charging port.

Now I see it installed the driver on my PC when I connect through the USB cable. But still not charging and it displays nothing when I try to charge it or start.

What can cause the problem and which part needs to be changed in order to work properly.

Thanks

Edited by: oldturkey03 ( )

Hello, When you had it apart did you look to see if any of the connections where still connected? Maybe a connector to the screen has been loosened? Or perhaps the screen itself has gone bad. I would suggest to check all the connections inside the device.

JSmith,

Thanks @JSmith, I tried to look for cables that can be loose. I only see Battery cable and microUSB Charger Flex Cable. I tightened both of them. Do I need to disassemble the phone further to look for more cables? Can the screen go bad by it self? Thanks

Mohamed Ali,

Have you checked your battery with a multimeter? Have you replaced the battery yet at all? You said "physical defect near by USB charging port " where is near by? Post an image of the "area" with the defect with your question.

oldturkey03,

This is an image that shows the defected area http://i.imgur.com/zZf2nfq.jpg

Mohamed Ali,

Post Answer

6

Score

Avatar
Sven Wilhelm
95

Answered

Accepted Answer

PermalinkHistory

I had this situation before with my Lumia 920. Just press the "Volume down" and power button for a few seconds to perform a soft reset. After the phone has started again, you have to set the date and time.

I tried hard and soft reset. Its more than that.

Mohamed Ali,

wow Sven Wilhelm , i have the same problem and it works when i press Volume down and power button at the same time for a few seconds. Thanx a lot, i almost packing it and send to Nokia for repair. :-)

Cymon,

Thanks Sven Wilhelm. I reset my phone now its working.

khurram,

Volume down and power button for a few seconds to perform a soft reset worked for me. www.sarthakpatel.in

Sarthak Patel,

Volume down and power button for a few seconds to perform a soft reset worked for me

Neeraj Ail,

Show 14 more comments

0

Score

Avatar
John Korondy
1

Answered

PermalinkHistory

http://jkorondy.com/Lumia920 to download firmware updater (Nokia Software Updater 4.1.0)

Edited by: John Korondy ( )

0

Score

Avatar
Abdelrhman
1

Answered

PermalinkHistory

Try the reset first. Press and hold the vol down+power+camera buttons. Release the power button when the phone vibrates and release the remaining 2 buttons about 5 seconds after that.

100%working Abdelrhman Abdalla

Edited by: oldturkey03 ( )

100% solution Pls do it like this: * Press and hold the vol down+power+camera buttons * when the phone vibrates Release the power button * about 5 seconds after that release the remaining 2 buttons

Abdelrhman,

0

Score

Avatar
McSkiltron
1

Answered

PermalinkHistory

a do soft reset ( vol- and power) bat not working! open device and disconnect battery flet and wait 10-15 sec then connect back and put back mask, and connect charger. this worked for me. ( sorry for bad english) :)

0

Score

Avatar
WeDoOurBes
t

1

Answered

PermalinkHistory

I tried everything; holding the two buttons down, then three, even charging it but nothing worked. please help me. Thanks.

If the reset described above, you may need to reload your firmware. See the instructions, warnings and software download at http://jkorondy.com/Lumia920

John Korondy,

Add Your Answer

View Statistics:

Today: 54

This Week: 550

This Month: 1,214

All Time: 16,669