0

Score

Avatar
Jan
11

Asked

Replaced dock assembly, can't adjust the ringer volume anymore etc.?

History

So I replaced the dock connector in a friend's iPhone 3G 16GB.

Things that DON'T work any more:

  • I can't hear anyone via the earpiece when I call
  • I can't adjust ringer volume when I don't use a headset (the volume icon appears when pressing the volume buttons, but without the grey/white bars)
  • There is no ringer any more at all
  • I can't use the speaker for the iPod app
  • Ringer/vibrator switch doesn't seem to work either
  • Nor does the proximity sensor

Things that DO work:

  • I can hear the start-up tone when I turn on the iPhone
  • I can call via headset, both speak and hear
  • I can put the phone on speaker
  • I can change the volume both when on speaker and via headset
  • I can change ringer volume when using a headset
  • Mic records sound

So the speaker of the new dock assembly is not broken and the volume buttons. What can be wrong?

Also at random times I get the warning "This accessory is not optimized for this iPhone".

Edited by: oldturkey03 ( ) , Jan ( )

Post Answer

0

Score

Avatar
Mitch Rush
4.4k

Answered

Accepted Answer

PermalinkHistory

It would seem your ear speaker is an easy one to figure out, of the 3 connectors that are on your digitizer lcd assembly the first one that you should hook up that slides in and has a jaw connector is probably not hooked up right, if you used a new speaker-dock assembly it could be bad, If not I have seen this happen many times and sometimes have had luck using a toothbrush to clean lint and debris from the dock connector, these symptoms state that the phone thinks it's plugged into a music dock and is trying to send everything to it, so if cleaning it doesn't work you may need a new one. love to hear back if this helps

Edited by: Mitch Rush ( )

So it doesn't have anything to do with the dock connector? I'll try cleaning then.

Jan,

It could be the dock connector, either a bad one or it may need to be cleaned, keep me posted please.

Mitch Rush,

I checked the jaw connector, seems to be fine. Dock connector is clean as well, but no changes. I put the iPhone in an old iPod dock (with the white remote) to charge and while it was plugged in there, the ringtone worked and was adjustable. Only the earpiece and proximity sensor problems persisted. How do I check if it's the jaw connector or the ribbon that's responsible? If it's the former I'm screwed, I guess.

Jan,

Add Your Answer

View Statistics:

Today: 0

This Week: 0

This Month: 4

All Time: 437